summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py21
1 files changed, 21 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..e214c33
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,21 @@
+#!/usr/bin/python
+#
+# Copyright (C) 2012-2014 Codethink Limited
+
+
+from distutils.core import setup
+import glob
+
+
+setup(name='lorry-controller',
+ description='Run Lorry on remote repositories in a controller manner',
+ author='Codethink Ltd',
+ author_email='baserock-dev@baserock.org',
+ url='http://www.baserock.com/',
+ scripts=['lorry-controller-webapp', 'lorry-controller-minion'],
+ packages=['lorrycontroller'],
+ data_files=[
+ ('share/lorry-controller/templates', glob.glob('templates/*')),
+ ('share/lorry-controller/static', glob.glob('static/*')),
+ ],
+ )