summaryrefslogtreecommitdiff
path: root/ACE/configure.ac
diff options
context:
space:
mode:
authorjtc <jtc@ae88bc3d-4319-0410-8dbf-d08b4c9d3795>2008-09-25 16:26:16 +0000
committerjtc <jtc@ae88bc3d-4319-0410-8dbf-d08b4c9d3795>2008-09-25 16:26:16 +0000
commit20090c449eab0006dac51c291900f530c41724ec (patch)
tree1e27ff67ae1e30b6d0ec4d5f82e50f780d1816ff /ACE/configure.ac
parent22733b10c899794e77f7f83fd54a9112edfa1052 (diff)
downloadATCD-20090c449eab0006dac51c291900f530c41724ec.tar.gz
ChangeLogTag: Thu Sep 25 16:23:26 UTC 2008 J.T. Conklin <jtc@acorntoolworks.com>
Diffstat (limited to 'ACE/configure.ac')
-rw-r--r--ACE/configure.ac46
1 files changed, 8 insertions, 38 deletions
diff --git a/ACE/configure.ac b/ACE/configure.ac
index 850a277380c..b5f1516c5be 100644
--- a/ACE/configure.ac
+++ b/ACE/configure.ac
@@ -505,8 +505,6 @@ AC_CHECK_HEADER([dlfcn.h],
ACE_CHECK_LACKS_HEADERS(inttypes.h malloc.h memory.h stdint.h)
-ACE_CHECK_HAS_HEADERS(bytesex.h)
-
AC_CHECK_HEADER([sys/msg.h],
[
ACE_CACHE_CHECK([if _KERNEL is needed for msg prototypes],
@@ -592,6 +590,8 @@ AC_CHECK_HEADER([sys/procfs.h],
ACE_CHECK_LACKS_HEADERS(arpa/inet.h)
+ACE_CHECK_HAS_HEADERS(bytesex.h)
+
ACE_CHECK_HAS_HEADERS(byteswap.h)
ACE_CHECK_LACKS_HEADERS(dirent.h)
@@ -1309,46 +1309,16 @@ AC_CHECK_TYPE([struct utsname],
[AC_DEFINE([ACE_LACKS_UTSNAME_T], 1,
[Define to 1 if the system lacks the type `struct utsname'.])],
[#include <sys/utsname.h>])
-
-ACE_CACHE_CHECK([for struct sembuf],[ace_cv_struct_sembuf],
- [
- dnl Some platforms may need to include some headers before <sys/sem.h>.
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
-#ifndef ACE_LACKS_SYS_TYPES_H
-# include <sys/types.h>
-#endif
-#include <sys/ipc.h>
-#include <sys/sem.h>
- ]],[[
- struct sembuf ace_sembuf;
- ]])],[
- ace_cv_struct_sembuf=yes
- ],[
-dnl Some compilers don't like the "struct" but we need the struct for
-dnl some platforms to resolve ambiguities between functions and
-dnl structures with with the same name. So, we try the same test but
-dnl without "struct" if the above test with "struct" fails. If both
-dnl tests fail, then we can be reasonably sure that we don't have the
-dnl structure we are testing for.
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
- [[
+AC_CHECK_TYPE([struct sembuf],
+ [],
+ [AC_DEFINE([ACE_LACKS_SEMBUF_T], 1,
+ [Define to 1 if the system lacks the type `struct sembuf'.])],
+ [
#ifndef ACE_LACKS_SYS_TYPES_H
# include <sys/types.h>
#endif
#include <sys/ipc.h>
-#include <sys/sem.h>
- ]],
- [[
- sembuf ace_sembuf;
- ]])],
- [
- ace_cv_struct_sembuf=yes
- ],
- [
- ace_cv_struct_sembuf=no
- ])
- ])
- ],,[AC_DEFINE([ACE_LACKS_SEMBUF_T])])
+#include <sys/sem.h>])
dnl Thanks to Konstantinos Margaritis <kmargar@cc.uoa.gr> for pointing out
dnl that struct siginfo_t may also be defined in signal.h