summaryrefslogtreecommitdiff
path: root/ACE/configure.ac
diff options
context:
space:
mode:
authorjtc <jtc@ae88bc3d-4319-0410-8dbf-d08b4c9d3795>2008-09-25 16:46:20 +0000
committerjtc <jtc@ae88bc3d-4319-0410-8dbf-d08b4c9d3795>2008-09-25 16:46:20 +0000
commitb53c7f0ae82c73c595d557b8c62a4d7515633f7e (patch)
tree31a25412387eee4034042f86cd2a52bed85f1297 /ACE/configure.ac
parenta2c11c6f1e52dbfacc389f7586bf1b7c6f4e01a1 (diff)
downloadATCD-b53c7f0ae82c73c595d557b8c62a4d7515633f7e.tar.gz
ChangeLogTag: Thu Sep 25 16:45:16 UTC 2008 J.T. Conklin <jtc@acorntoolworks.com>
Diffstat (limited to 'ACE/configure.ac')
-rw-r--r--ACE/configure.ac25
1 files changed, 0 insertions, 25 deletions
diff --git a/ACE/configure.ac b/ACE/configure.ac
index b5f1516c5be..2d2376f0f17 100644
--- a/ACE/configure.ac
+++ b/ACE/configure.ac
@@ -2236,31 +2236,6 @@ if test "$ace_cv_lib_auto_ptr_class" = yes; then
],,[AC_DEFINE([ACE_AUTO_PTR_LACKS_RESET])])
fi dnl test $ace_cv_lib_auto_ptr_class=yes
-dnl Check if platform supports placement new operator
-ACE_CACHE_CHECK([for C++ placement new operator],
- [ace_cv_feature_placement_new],[
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
-#if defined (ACE_HAS_NEW_NO_H)
-# include <new>
-#elif defined (ACE_HAS_NEW_H)
-# include <new.h>
-#endif
-
-class foo
-{
-public:
- void *operator new (size_t, void *p) { return p; }
-};
- ]],[[
-int *x = 0;
-foo *f = new (x) foo;
- ]])],[
- ace_cv_feature_placement_new=yes
- ],[
- ace_cv_feature_placement_new=no
- ])
- ],,[AC_DEFINE([ACE_LACKS_PLACEMENT_OPERATOR_NEW])])
-
dnl Check if platform supports placement delete operator
ACE_CACHE_CHECK([for C++ placement delete operator],
[ace_cv_feature_placement_delete],[