summaryrefslogtreecommitdiff
path: root/ACE/debian/changelog
diff options
context:
space:
mode:
authorJohnny Willemsen <jwillemsen@remedy.nl>2010-09-07 10:59:20 +0000
committerJohnny Willemsen <jwillemsen@remedy.nl>2010-09-07 10:59:20 +0000
commit765fb0f20770d9cc6e4a0c2d9fb6f388f5ea7d2f (patch)
tree0c5ce964768d1621e7f31453c3893cc3f1f5c97d /ACE/debian/changelog
parent730f0547f9e33c3f10dbd2babb75ace20686c236 (diff)
downloadATCD-765fb0f20770d9cc6e4a0c2d9fb6f388f5ea7d2f.tar.gz
Tue Sep 7 10:52:59 UTC 2010 Johnny Willemsen <jwillemsen@remedy.nl>
* Kokyu/DSRT_Direct_Dispatcher_Impl_T.cpp: Use ACE_GUARD * Kokyu/Dispatcher_Task.cpp: Initialise pointer with 0 * PROBLEM-REPORT-FORM: * VERSION: Updated support email addresses * ace/ACE.inl: Layout changes * ace/ACE.cpp: Layout changes, simplified some ifdef checks * ace/Auto_IncDec_T.h: * ace/Env_Value_T.h: Use ACE_Copy_Disabled * ace/Bound_Ptr.inl: Documentation updates * ace/CORBA_macros.h: Removed all deprecated macros * ace/Dynamic_Service_Base.cpp: Use ACE_GUARD_RETURN * ace/Event_Handler_T.h: * ace/Event_Handler_T.inl: * ace/Event_Handler_T.cpp: Removed checks for ACE_HAS_TEMPLATE_TYPEDEFS, I think all compilers have this now, let us see if nothing breaks * ace/FILE.h: Doxygen updates * ace/Future.h: * ace/Future.cpp: Use mutex defines * ace/Future_Set.h: Use ACE_Copy_Disabled * ace/Future_Set.cpp: Initialise pointer with 0 * ace/Global_Macros.h: Removed checks for ACE_HAS_TEMPLATE_TYPEDEFS, doxygen changes, make it possible for users to redefine ACE_GUARD macros * ace/Guard_T.h: * ace/Guard_T.inl: * ace/Guard_T.cpp: Doxygen changes, disable ACE_Guard checks for this file * ace/Hash_Map_Manager_T.h: * ace/Hash_Multi_Map_Manager_T.h: * ace/Map_Manager.h: Update to indicate the usage of ACE_GUARD * ace/INET_Addr.h: Doxygen changes * ace/Local_Tokens.h: Disable part of this file for ACE_Guard fuzz check * ace/Log_Msg.cpp: Use ACE_OS::thr_self * ace/Malloc_T.h: Disable part of this file for ACE_Guard fuzz check, doxygen changes * ace/Message_Queue_T.h: * ace/Message_Queue_T.cpp: * ace/Message_Queue_Vx.h: * ace/Message_Queue_Vx.cpp: Removed ACE_Guard argument to some methods, not used and now cause fuzz to fail * ace/Mutex.h: * ace/Mutex.inl: Added non const lock(), this fixes bugzilla 3878. Thanks to Susan Finster <sfinster at daetwyler-rd dot com> for reporting this * ace/Null_Barrier.h: * ace/Null_Condition.h: * ace/Null_Mutex.h: * ace/Null_Semaphore.h: Removed old comments, disable part for ACE_Guard, removed ACE_Null_Mutex_Guard * ace/OS_NS_Thread.cpp: Layout changes, use ACE_Guard * ace/OS_NS_poll.cpp: * ace/OS_NS_sys_select.cpp: Layout changes * ace/OS_NS_sys_socket.inl: Comment change * ace/Read_Buffer.h: * ace/Remote_Tokens.h: * ace/SOCK.h: Doxygen changes * ace/SOCK_Connector.h: * ace/SOCK_Dgram_Mcast.h: Doxygen changes * ace/SOCK_Connector.cpp: Layout and const changes * ace/Select_Reactor.h: Disable part of this file for ACE_Guard fuzz check * ace/Service_Gestalt.h: Use ACE_Copy_Disabled * ace/Sig_Handler.cpp: Use ACE_GUARD macros * ace/Synch_Traits.h: Removed ACE_HAS_TEMPLATE_TYPEDEFS checks * ace/TSS_T.h: * ace/TSS_T.cpp: Use ACE_Copy_Disabled, reworked some code to fix ACE_Guard fuzz checks * ace/Task_Ex_T.h: Use ACE_Copy_Disabled * apps/Gateway/Peer/Peer.cpp: * apps/JAWS/server/HTTP_Server.cpp: * apps/JAWS/server/JAWS_IO.cpp: Initialise pointers with 0 * apps/JAWS/server/HTTP_Helpers.cpp: Use ACE_GUARD macros * apps/JAWS2/JAWS/Cache_Hash_T.cpp: * apps/JAWS2/JAWS/Cache_Manager_T.cpp: * apps/JAWS2/JAWS/Cache_Object.cpp: * apps/JAWS2/JAWS/Concurrency.cpp: * apps/JAWS2/JAWS/FILE.cpp: * apps/JAWS2/JAWS/Jaws_IO.cpp: * apps/JAWS2/JAWS/Reaper.cpp: * apps/JAWS3/jaws3/FILE.cpp: Use ACE_GUARD macros * apps/gperf/src/Options.cpp: Rename of local variable so that we don't need to disable ACE_OS fuzz check * bin/fuzz.pl: Improved ACE_Guard checks and enable this one by default * bin/generate_doxygen.pl: Let DANCE use the CIAO version file for the moment * bin/make_release.py: Don't create static and wince solutions as part of the release anymore, if you use these, generate them by hand in the future. Added vc10 project files * examples/APG/Proactor/HA_Proactive_Status.cpp: * examples/APG/Reactor/Client.cpp: * examples/APG/Reactor/HAStatus.cpp: * examples/APG/Streams/Answerer.cpp: * examples/APG/Streams/CommandStream.cpp: * examples/APG/ThreadManagement/Pool.cpp: * examples/APG/ThreadPools/LF_ThreadPool.cpp: * examples/APG/ThreadPools/Task_ThreadPool.cpp: * examples/APG/ThreadSafety/Semaphore.cpp: * examples/APG/Threads/Message_Blocks.cpp: * examples/APG/Threads/Message_Queue.cpp: * examples/ASX/Message_Queue/bounded_buffer.cpp: * examples/ASX/Message_Queue/priority_buffer.cpp: * examples/Bounded_Packet_Relay/Thread_Bounded_Packet_Relay.cpp: * examples/C++NPv2/AIO_Client_Logging_Daemon.cpp: * examples/C++NPv2/display_logfile.cpp: * examples/IPC_SAP/UPIPE_SAP/ex1.cpp: * examples/Reactor/Misc/test_demuxing.cpp: * examples/Reactor/WFMO_Reactor/Talker.cpp: * examples/Threads/barrier2.cpp: * examples/Threads/thread_pool.cpp: Initialise pointers with 0 * examples/APG/ThreadPools/ThreadPool.cpp: Use ACE_Thread_ID to store a print a thread id using ACE_DEBUG, that is the only way that is 100% portable * examples/APG/Threads/Guards.cpp: Disable ACE_Guard fuzz * examples/Threads/reader_writer.cpp: * examples/Threads/recursive_mutex.cpp: Use ACE_GUARD macros * examples/Threads/thread_specific.cpp: * examples/Threads/tss1.cpp: Removed code not used * include/makeinclude/platform_g++_common.GNU: Added CROSS_COMPILE support to this file * include/makeinclude/platform_linux.GNU: * include/makeinclude/platform_linux_common.GNU: Moved some bits to platform_g++_common.GNU, works with G++ in general * include/makeinclude/platform_qnx_neutrino.GNU: * include/makeinclude/platform_qnx_rtp_gcc.GNU: Cleanup * netsvcs/lib/Log_Message_Receiver.h: * netsvcs/lib/Log_Message_Receiver.cpp: Use ACE_GUARD macros * performance-tests/Misc/Misc.mpc: Enable test_guard * performance-tests/Misc/test_guard.cpp: Made this compiling again * performance-tests/Synch-Benchmarks/Base_Test/Baseline_Test.cpp: * performance-tests/TCP/tcp_test.cpp: Renamed variable to not need ACE_OS fuzz disable code * protocols/ace/HTBP/HTBP_ID_Requestor.cpp: * protocols/ace/HTBP/HTBP_Session.cpp: Use ACE_GUARD macros * protocols/ace/RMCast/Acknowledge.h: * protocols/ace/RMCast/Acknowledge.cpp: * protocols/ace/RMCast/Bits.h: * protocols/ace/RMCast/Flow.h: * protocols/ace/RMCast/Flow.cpp: * protocols/ace/RMCast/Fragment.h: * protocols/ace/RMCast/Fragment.cpp: * protocols/ace/RMCast/Link.h: * protocols/ace/RMCast/Link.cpp: * protocols/ace/RMCast/Parameters.h: * protocols/ace/RMCast/Protocol.h: * protocols/ace/RMCast/Protocol.cpp: * protocols/ace/RMCast/Reassemble.h: * protocols/ace/RMCast/Reassemble.cpp: * protocols/ace/RMCast/Retransmit.h: * protocols/ace/RMCast/Retransmit.cpp: * protocols/ace/RMCast/Simulator.h: * protocols/ace/RMCast/Simulator.cpp: * protocols/ace/RMCast/Socket.h: * protocols/ace/RMCast/Socket.cpp: * protocols/ace/RMCast/Stack.h: * protocols/ace/RMCast/Stack.cpp: * protocols/ace/TMCast/FaultDetector.hpp: * protocols/ace/TMCast/Group.cpp: * protocols/ace/TMCast/Group.hpp: * protocols/ace/TMCast/GroupFwd.hpp: * protocols/ace/TMCast/LinkListener.hpp: * protocols/ace/TMCast/MTQueue.hpp: * protocols/ace/TMCast/MTQueue.cpp: * protocols/ace/TMCast/Messaging.hpp: * protocols/ace/TMCast/Protocol.hpp: * protocols/ace/TMCast/Protocol.cpp: * protocols/ace/TMCast/TransactionController.hpp: Removed commented out code, Id changes, disable ACE_Guard check for this project * rpmbuild/ace-tao.spec: Fixed some problems in this spec file * tests/Aio_Platform_Test.cpp: * tests/Basic_Types_Test.cpp: * tests/Bug_1576_Regression_Test.cpp: * tests/Bug_3532_Regression_Test.cpp: * tests/Bug_3673_Regression_Test.cpp: * tests/Bug_3709_Regression_Test.cpp: * tests/Bug_3744_Regression_Test.cpp: * tests/Compiler_Features_03_Test.cpp: * tests/Compiler_Features_09_Test.cpp: * tests/Compiler_Features_13_Test.cpp: * tests/Compiler_Features_14_Test.cpp: * tests/Env_Value_Test.cpp: * tests/Hash_Map_Bucket_Iterator_Test.cpp: * tests/Logging_Strategy_Test.cpp: * tests/MT_SOCK_Test.cpp: * tests/Pipe_Test.cpp: * tests/Priority_Task_Test.cpp: * tests/Proactor_UDP_Test.cpp: * tests/QtReactor_Test.cpp: * tests/Reactor_Notification_Queue_Test.cpp: * tests/Reactor_Registration_Test.cpp: * tests/Reference_Counted_Event_Handler_Test.cpp: * tests/Time_Service_Test.cpp: Zapped ACE_RCSID * tests/Message_Block_Test.cpp: * tests/Multicast_Test_IPV6.cpp: Initialise pointer with 0 * tests/Reader_Writer_Test.cpp: Use ACE_GUARD * tests/Recursive_Mutex_Test.cpp: Disable ACE_Guard fuzz for part of this file * tests/Bug_3878_Regression_Test.cpp: New test for bugzilla 3878 * tests/SSL/Bug_2912_Regression_Test.cpp: * tests/TP_Reactor_Test.cpp: Use ACE_GUARD * tests/Simple_Message_Block_Test.cpp: * tests/Svc_Handler_Test.cpp: * tests/Thread_Pool_Test.cpp: * tests/UPIPE_SAP_Test.cpp: Initialise pointers with 0 * tests/Thread_Mutex_Test.cpp: Disable ACE_Guard fuzz * tests/Upgradable_RW_Test.cpp: Use ACE_GUARD * tests/run_test.lst: * tests/tests.mpc: Added 3878
Diffstat (limited to 'ACE/debian/changelog')
-rw-r--r--ACE/debian/changelog37
1 files changed, 22 insertions, 15 deletions
diff --git a/ACE/debian/changelog b/ACE/debian/changelog
index 3c557761b45..cb759272ea6 100644
--- a/ACE/debian/changelog
+++ b/ACE/debian/changelog
@@ -1,3 +1,10 @@
+ace (5.8.2-1) unstable; urgency=low
+
+ [ Johnny Wilemsen ]
+ * New upstream release
+
+ -- Johnny Willemsen <jwillemsen@remedy.nl> Mon, 4 Sep 2010 20:00:00 +0100
+
ace (5.7.7-1) unstable; urgency=low
[ Marek Brudka ]
@@ -8,7 +15,7 @@ ace (5.7.7-1) unstable; urgency=low
* Added PerlACE to mpc-ace. This should resolve #522557
* Replaced find [C,S,A].[h,inl] by 2-pass mpc generation
* Remove obsolete patches
-
+
-- Marek Brudka <mbrudka@aster.pl> Sat, 27 Mar 2010 20:00:00 +0100
ace (5.7.5-2) unstable; urgency=low
@@ -58,9 +65,9 @@ ace (5.7.5-1) unstable; urgency=low
* fixed fidone once again
* created gperf-ace-5.7.5 and gperf-ace-dev package for gperf runtime libraries
* included number of runtime and static libraries with headers (Monitor, ZIOP, ETCL, Catior) to libtao-orbsvcs-* packages
- * renamed split-cpp to split-cpp.pl in libace-dev to follow the upstream
+ * renamed split-cpp to split-cpp.pl in libace-dev to follow the upstream
conventions
- * renamed utilities (ns{add,del,list> to tao_ns{add,del,list}) in tao-utils
+ * renamed utilities (ns{add,del,list> to tao_ns{add,del,list}) in tao-utils
to follow the upstream changes
* removed permission fixes for example in debian/rules as there is nothing to fix
* created libace_gperf runtime and devel libraries
@@ -91,7 +98,7 @@ ace (5.6.3-6) unstable; urgency=low
[ Pau Garcia i Quiles ]
* Add new patches:
- Remove duplicate files from .mpc files so that Makefile.am files do
- not have duplicates
+ not have duplicates
- Run autoupdate and autoreconf in the ACE and TAO directories in order
to update from libtool 1.5 (what upstream uses) to libtool 2.2
@@ -332,9 +339,9 @@ ace (5.4.7-6) unstable; urgency=low
* debian/patches/16-g++4-visibility-tweaks.dpatch:
Backport upstream tweaks for g++ 4 visibility feature and disable
visibility hiding for now. (Closes: #324271).
- * debian/rules: g++ 4.0.2 was ICE'ing on #pragma once. This is no
+ * debian/rules: g++ 4.0.2 was ICE'ing on #pragma once. This is no
longer true as of g++-4.0_4.0.2-4, so we can use g++4 again. For the
- record, another possible fix was to #define ACE_LACKS_PRAGMA_ONCE in
+ record, another possible fix was to #define ACE_LACKS_PRAGMA_ONCE in
`$ACE_ROOT/ace/config.h`.
* Add `c2a` suffix to all libs for libstdc++ allocator change.
(Closes: #339142).
@@ -385,7 +392,7 @@ ace (5.4.7-1) unstable; urgency=low
-- Konstantinos Margaritis <markos@debian.org> Fri, 12 Aug 2005 12:45:13 +0300
ace (5.4.2.1.0-4) unstable; urgency=high
-
+
* Thomas Girard <thomas.g.girard@free.fr>
- debian/control:
o libacexml-dev depends on libace-dev.
@@ -396,7 +403,7 @@ ace (5.4.2.1.0-4) unstable; urgency=high
reported by lintian.
- debian/libciao-dev.install: add missing .idl and .pidl files.
(Closes: #307258)
-
+
-- Thomas Girard <thomas.g.girard@free.fr> Mon, 2 May 2005 19:30:01 +0200
ace (5.4.2.1.0-3) unstable; urgency=high
@@ -490,9 +497,9 @@ ace (5.4.2.1-1) unstable; urgency=low
* Konstantinos Margaritis
- Fixed missed path for libACE.so.5.4.2 in dh_shlibdeps
- Fixed incorrect timestamp of original archive (1970 etc).
-
+
-- Konstantinos Margaritis <markos@debian.org> Thu, 2 Sep 2004 23:04:56 +0200
-
+
ace (5.4.0.1-1.1) unstable; urgency=low
* Fixed ACE_NDEBUG configuration of ACE. (Closes: #242881)
@@ -558,7 +565,7 @@ ace (5.3.1-7) unstable; urgency=low
ace (5.3.1-6) unstable; urgency=low
- * Added the ORB services .idl files that were left out from the
+ * Added the ORB services .idl files that were left out from the
libtao-orbsvcs-dev package. (Closes: #213568)
-- Konstantinos Margaritis <markos@debian.org> Sun, 5 Oct 2003 12:31:21 +0300
@@ -584,7 +591,7 @@ ace (5.3.1-3) unstable; urgency=low
* Updated to new standards version 3.6.1
* Fixed the section of a couple of packages.
- * Now the getrlimit, etc functions are always defined
+ * Now the getrlimit, etc functions are always defined
as ints. g++ 3.x does not complain anymore (Closes: #104681).
-- Konstantinos Margaritis <markos@debian.org> Tue, 16 Sep 2003 10:31:03 +0300
@@ -599,7 +606,7 @@ ace (5.3.1-2) unstable; urgency=low
* Full doxygen documentation not included due to size concerns.
(Closes: #108749).
* tao-config included in libtao-dev. (Closes: #159234).
- * All -dev packages carry their respective examples in full and
+ * All -dev packages carry their respective examples in full and
uncompressed. (Closes: #52145, #76967).
* libACE.a is compiled with thread support enabled. (Closes: #126717).
dbbalancer now builds successfully with -static.
@@ -640,7 +647,7 @@ ace (5.2.4-1.2) unstable; urgency=low
ace (5.2.4-1.1) unstable; urgency=low
- * gcc-3.2 transition, NMU patch by Andreas Metzler <ametzler@debian.org>
+ * gcc-3.2 transition, NMU patch by Andreas Metzler <ametzler@debian.org>
* (Closes: #188328)
-- Konstantinos Margaritis <markos@debian.org> Fri, 11 Apr 2003 23:25:38 +0200
@@ -710,7 +717,7 @@ ace (5.1.8-5) unstable; urgency=low
5.0 debian packages, since both sets of packages have files with the
same name. libace5.1-dev also conflicts with libace4.6-dev. (#74031)
* Added xlib6g-dev to the list of build dependencies. The X11 libraries
- aren't strictly necessary to build ACE, but the Debian packages enable
+ aren't strictly necessary to build ACE, but the Debian packages enable
ACE's XtReactor support.
* Updated `README.Debian'. The Debian ACE packages are no longer built
using experimental ACE Configuration Project distributions. They are