summaryrefslogtreecommitdiff
path: root/ACE/tests/Makefile.am
diff options
context:
space:
mode:
authorcoryan <coryan@ae88bc3d-4319-0410-8dbf-d08b4c9d3795>2009-07-02 11:43:47 +0000
committercoryan <coryan@ae88bc3d-4319-0410-8dbf-d08b4c9d3795>2009-07-02 11:43:47 +0000
commit391431c8260d8525af265fc39291508ca8840208 (patch)
treee6f1cf10a12705e6e2430956ae3be8bb3fb4b5cc /ACE/tests/Makefile.am
parent4ae3513ca392d3dfefb9343f559f3c4a42fb1e85 (diff)
downloadATCD-391431c8260d8525af265fc39291508ca8840208.tar.gz
Thu Jul 2 11:38:15 UTC 2009 Carlos O'Ryan <coryan@glamdring>
* tests/Compiler_Features_04_Test.cpp: Test for std::set<> * tests/Compiler_Features_05_Test.cpp: Test for std::queue<>, this is a different sort of test because std::queue<> is an adaptor, not a collection. The default collection is a std::deque<>, so we are testing default template parameters at the same time. * tests/Compiler_Features_06_Test.cpp: Test for std::set<> with a different order function. * tests/run_test.lst: * tests/Makefile.am: * tests/tests.mpc: Add the compilation / run parafernalia.
Diffstat (limited to 'ACE/tests/Makefile.am')
-rw-r--r--ACE/tests/Makefile.am60
1 files changed, 60 insertions, 0 deletions
diff --git a/ACE/tests/Makefile.am b/ACE/tests/Makefile.am
index 232fd72b34b..7ed03c3cf57 100644
--- a/ACE/tests/Makefile.am
+++ b/ACE/tests/Makefile.am
@@ -703,6 +703,66 @@ Compiler_Features_03_Test_LDADD = \
endif !BUILD_ACE_FOR_TAO
+## Makefile.Compiler_Features_04_Test.am
+
+if !BUILD_ACE_FOR_TAO
+
+noinst_PROGRAMS += Compiler_Features_04_Test
+
+Compiler_Features_04_Test_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR)
+
+Compiler_Features_04_Test_SOURCES = \
+ $(ACE_ROOT)/tests/Main.cpp \
+ Compiler_Features_04_Test.cpp \
+
+Compiler_Features_04_Test_LDADD = \
+ libTest_Output.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif !BUILD_ACE_FOR_TAO
+
+## Makefile.Compiler_Features_05_Test.am
+
+if !BUILD_ACE_FOR_TAO
+
+noinst_PROGRAMS += Compiler_Features_05_Test
+
+Compiler_Features_05_Test_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR)
+
+Compiler_Features_05_Test_SOURCES = \
+ $(ACE_ROOT)/tests/Main.cpp \
+ Compiler_Features_05_Test.cpp \
+
+Compiler_Features_05_Test_LDADD = \
+ libTest_Output.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif !BUILD_ACE_FOR_TAO
+
+## Makefile.Compiler_Features_06_Test.am
+
+if !BUILD_ACE_FOR_TAO
+
+noinst_PROGRAMS += Compiler_Features_06_Test
+
+Compiler_Features_06_Test_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR)
+
+Compiler_Features_06_Test_SOURCES = \
+ $(ACE_ROOT)/tests/Main.cpp \
+ Compiler_Features_06_Test.cpp \
+
+Compiler_Features_06_Test_LDADD = \
+ libTest_Output.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif !BUILD_ACE_FOR_TAO
+
## Makefile.Config_Test.am
if !BUILD_ACE_FOR_TAO