summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorOssama Othman <ossama-othman@users.noreply.github.com>2003-04-17 23:16:14 +0000
committerOssama Othman <ossama-othman@users.noreply.github.com>2003-04-17 23:16:14 +0000
commit7b4c35806bd1119420d6b231f81df06166d97ab2 (patch)
tree49ecf01b243f57c814c3dc71bcf1cf10b432dfde /Makefile.am
parent5c9f212b4c3a76576f19660e6184e63beade6451 (diff)
downloadATCD-7b4c35806bd1119420d6b231f81df06166d97ab2.tar.gz
ChangeLogTag:Thu Apr 17 16:15:24 2003 Ossama Othman <ossama@dre.vanderbilt.edu>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am55
1 files changed, 31 insertions, 24 deletions
diff --git a/Makefile.am b/Makefile.am
index efa36037bf8..e6add9fa4d8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -10,10 +10,6 @@
## Process this file with automake to create Makefile.in
##
-## The number in AUTOMAKE_OPTIONS is the minimum required version automake
-## needed to process this file.
-AUTOMAKE_OPTIONS = 1.4 #check-news
-
bin_SCRIPTS = ace-config
man_MANS = ace-config.1
@@ -22,10 +18,10 @@ man_MANS = ace-config.1
## The docs directory is currently handled by the "dist-hook" makefile target.
SUBDIRS = \
ace \
- netsvcs \
- tests \
apps \
- man
+ tests
+## netsvcs \
+## man
##SUBDIRS = \
## docs \
@@ -38,31 +34,33 @@ SUBDIRS = \
## etc \
## includes
+## Additional flags to pass to `aclocal' when invoked by the generated
+## Makefile. In particular, add ACE's `m4' directory to the macro
+## search path.
+ACLOCAL_AMFLAGS = -I m4
+
+## If any of these files are modified, `configure' will be
+## regenerated.
+CONFIGURE_DEPENDENCIES = \
+ m4/ace.m4 \
+ m4/acinclude.m4 \
+ m4/compiler.m4 \
+ m4/config_h.m4 \
+ m4/features.m4 \
+ m4/platform.m4 \
+ m4/subsets.m4 \
+ m4/threads.m4
+
## For some reason, automake doesn't include acconfig.h in the distribution
EXTRA_DIST = \
ACE-INSTALL.html \
ACE-install.sh \
- BIBLIOGRAPHY \
- ChangeLog-93 \
- ChangeLog-94 \
- ChangeLog-95 \
- ChangeLog-96a \
- ChangeLog-96b \
- ChangeLog-97a \
- ChangeLog-97b \
- ChangeLog-98a \
- ChangeLog-98b \
- ChangeLog-99a \
- ChangeLog-99b \
FAQ \
PROBLEM-REPORT-FORM \
VERSION \
- acconfig.h \
ace-config.in \
ace-config.1.in \
- aceConf.sh.in \
- ltcf-c.sh \
- ltcf-cxx.sh
+ aceConf.sh.in
DISTCLEANFILES = ace-config aceConf.sh ace-config.1
@@ -79,7 +77,12 @@ confexec_DATA = aceConf.sh
## Directories to include in the distribution but which I am too lazy to
## create Makefile.am files for. A Makefile.am for these directories isn't
## needed anyway.
-ACE_EXTRA_DIST = bin docs m4
+ACE_EXTRA_DIST = ChangeLogs bin docs m4
+
+## Automake recognized target. Appends these rules to the "all"
+## target.
+all-local:
+ test -d bin || ($(LN_S) $(top_srcdir)/bin bin && touch ace-bin-stamp)
## Clean up some additional files/directories possibly created during
## the configure script tests.
@@ -99,3 +102,7 @@ dist-hook:
list=`find $(distdir) -type d -name CVS -print`; for p in $$list; do \
rm -rf $$p; \
done
+
+## Clean up files and directories created by this Makefile.
+distclean-local:
+ -test -f ace-bin-stamp && rm bin ace-bin-stamp