summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorOssama Othman <ossama-othman@users.noreply.github.com>1999-04-03 21:28:28 +0000
committerOssama Othman <ossama-othman@users.noreply.github.com>1999-04-03 21:28:28 +0000
commitfb9958dfe85fbd1c429fb7ee1a3dbddf1e778229 (patch)
tree6196d4e5c9301bf63c8aff9e7dc8983dd66c71f6 /Makefile.am
parent8dc47973d6c4c7f0080625bf4368bd280d24e350 (diff)
downloadATCD-fb9958dfe85fbd1c429fb7ee1a3dbddf1e778229.tar.gz
Added targets to clean up files and directories created during
compilation. Automake will setup the `clean-local' targets to run automatically whenever a `make clean' is done.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 42c017cefd4..f7e54e87d86 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -112,7 +112,13 @@ endif
## Directories to include in the distribution but which I am too lazy to
## create Makefile.am files for. A Makefile.am for these directories isn't
## needed anyway.
-ACE_EXTRA_DIST = $(top_srcdir)/bin $(top_srcdir)/docs $(top_srcdir)/m4
+ACE_EXTRA_DIST = bin docs m4
+
+## Clean up some additional files/directories possibly created during
+## the configure script tests.
+clean-local:
+ -rm -f *.bak *.rpo *.sym lib*.*_pure_* Makefile.old core
+ -rm -rf ptrepository Templates.DB gcctemp.c gcctemp so_locations
## Make sure config.h doesn't get into the distribution
## since it may later intefere with the newly generated
@@ -121,7 +127,8 @@ ACE_EXTRA_DIST = $(top_srcdir)/bin $(top_srcdir)/docs $(top_srcdir)/m4
## config.h is platform specific.
dist-hook:
-rm -f $(distdir)/ace/config.h
- tar cf - $(ACE_EXTRA_DIST) | (cd $(distdir); tar xfBp -)
+ (cd $(top_srcdir); tar cf - $(ACE_EXTRA_DIST)) | (cd $(distdir); \
+ tar xfBp -)
list=`find $(distdir) -type d -name CVS -print`; for p in $$list; do \
rm -rf $$p; \
done