summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorOssama Othman <ossama-othman@users.noreply.github.com>1999-03-25 19:38:31 +0000
committerOssama Othman <ossama-othman@users.noreply.github.com>1999-03-25 19:38:31 +0000
commit6f101e7c4ffa65869c101f520d143d09880bd07b (patch)
tree17cd7bf497c093429256436ec894ac6f43fa1a46 /Makefile.am
parent369d75b891798d182bfca561802c7ba9f9a4ed0c (diff)
downloadATCD-6f101e7c4ffa65869c101f520d143d09880bd07b.tar.gz
* Makefile.am (ACE.ifnames):
Placed rule generation of ACE.ifnames within a MAINTAINER_MODE automake conditional. If a `--enable-maintainer-mode' option isn't given on the configure script command line then don't generate a new `ACE.ifnames' file. * configure.in: Added AM_MAINTAINER_MODE so that maintainer level Makefile features are disabled by default. * acconfig.h: Added ACE_HAS_BROKEN_MAP_FAILED macro for platforms that do not cast MAP_FAILED to a (void *). Defining this macro prevents compilers on those platforms from complaining about assigning an int to a (void *). Thanks to Roland Gigler <roland@mch.pn.siemens.de> for providing feedback about this.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 937e6aff64a..f3fa06cc7c3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -101,8 +101,13 @@ ace-config.1: ace-config.1.in Makefile
noinst_DATA = ACE.ifnames
ACE.ifnames: ChangeLog acconfig.h
- ifnames ace/*.{h,i,cpp} | sed -e 's/ .*//g' > ACE.ifnames
-
+if MAINTAINER_MODE
+ rm -f $@
+ ifnames $(top_srcdir)/ace/*.{h,i,cpp} | sed -e 's/ .*//g' \
+ > $(top_srcdir)/$@
+else
+ touch $(top_srcdir)/$@
+endif
## Directories to include in the distribution but which I am too lazy to
## create Makefile.am files for. A Makefile.am for these directories isn't