summaryrefslogtreecommitdiff
path: root/TAO/orbsvcs/orbsvcs/Time/Makefile.am
diff options
context:
space:
mode:
authornobody <nobody@ae88bc3d-4319-0410-8dbf-d08b4c9d3795>2004-09-16 21:19:02 +0000
committernobody <nobody@ae88bc3d-4319-0410-8dbf-d08b4c9d3795>2004-09-16 21:19:02 +0000
commit40fdc8a404e75ab03b68cc62e9987cf208fd8c30 (patch)
tree37d9c4d3abe4aefd8a34ed797883dd2cd4862ca7 /TAO/orbsvcs/orbsvcs/Time/Makefile.am
parentc254b281f1b9a4ca19dd0c3ee73a0654a7718909 (diff)
downloadATCD-40fdc8a404e75ab03b68cc62e9987cf208fd8c30.tar.gz
This commit was manufactured by cvs2svn to create branchtypecode-overhaul
'typecode-overhaul'.
Diffstat (limited to 'TAO/orbsvcs/orbsvcs/Time/Makefile.am')
-rw-r--r--TAO/orbsvcs/orbsvcs/Time/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/TAO/orbsvcs/orbsvcs/Time/Makefile.am b/TAO/orbsvcs/orbsvcs/Time/Makefile.am
new file mode 100644
index 00000000000..7b1f4668c1a
--- /dev/null
+++ b/TAO/orbsvcs/orbsvcs/Time/Makefile.am
@@ -0,0 +1,42 @@
+##---------------------------------------------------------------------------
+## $Id$
+##
+## Makefile for TAO's Time Service library
+##
+##---------------------------------------------------------------------------
+
+##
+## Process this file with automake to create Makefile.in
+##
+
+## The number in AUTOMAKE_OPTIONS is the minimum required version automake
+## needed to process this file.
+AUTOMAKE_OPTIONS = 1.4
+
+INCLUDES = -I$(top_builddir) -I$(top_srcdir)
+
+lib_LTLIBRARIES = libTAO_Time.la
+
+libTAO_Time_la_LDADD = \
+ $(top_builddir)/ace/libACE.la $(top_builddir)/TAO/tao/libTAO.la
+
+libTAO_Time_la_SOURCES = \
+ TAO_TIO.cpp \
+ TAO_Time_Service_Clerk.cpp \
+ TAO_Time_Service_Server.cpp \
+ TAO_UTO.cpp \
+ Timer_Helper.cpp
+
+noinst_HEADERS = \
+ TAO_TIO.h \
+ TAO_Time_Service_Clerk.h \
+ TAO_Time_Service_Server.h \
+ TAO_UTO.h \
+ Timer_Helper.h
+
+## Clean up some additional files/directories possibly created during
+## the configure script tests.
+clean-local:
+ -rm -f *.bak *.rpo *.sym lib*.*_pure_* Makefile.old core
+ -rm -rf ptrepository Templates.DB gcctemp.c gcctemp so_locations
+