summaryrefslogtreecommitdiff
path: root/TAO/tests/Leader_Followers/Makefile.am
diff options
context:
space:
mode:
authorjtc <jtc@ae88bc3d-4319-0410-8dbf-d08b4c9d3795>2006-12-12 17:41:07 +0000
committerjtc <jtc@ae88bc3d-4319-0410-8dbf-d08b4c9d3795>2006-12-12 17:41:07 +0000
commit97abf95c241aae196ae3ad4b34475c0482d51a99 (patch)
treee050d840ca1175463c78f571dc14ea9807d22774 /TAO/tests/Leader_Followers/Makefile.am
parent3f7dfc3b88e512b2c86a296fae2ba4639736a963 (diff)
downloadATCD-97abf95c241aae196ae3ad4b34475c0482d51a99.tar.gz
ChangeLogTag: Tue Dec 12 17:34:25 UTC 2006 J.T. Conklin <jtc@acorntoolworks.com>
Diffstat (limited to 'TAO/tests/Leader_Followers/Makefile.am')
-rw-r--r--TAO/tests/Leader_Followers/Makefile.am50
1 files changed, 13 insertions, 37 deletions
diff --git a/TAO/tests/Leader_Followers/Makefile.am b/TAO/tests/Leader_Followers/Makefile.am
index 43a1d56f8cf..f8fad6f84ef 100644
--- a/TAO/tests/Leader_Followers/Makefile.am
+++ b/TAO/tests/Leader_Followers/Makefile.am
@@ -17,14 +17,10 @@ TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(T
TAO_ROOT = $(top_srcdir)
noinst_PROGRAMS =
-CLEANFILES =
-BUILT_SOURCES =
-## Makefile.Leader_Followers_Server.am
-
-if BUILD_EXCEPTIONS
+## Makefile.Leader_Followers_Idl.am
-BUILT_SOURCES += \
+BUILT_SOURCES = \
testC.cpp \
testC.h \
testC.inl \
@@ -32,7 +28,7 @@ BUILT_SOURCES += \
testS.h \
testS.inl
-CLEANFILES += \
+CLEANFILES = \
test-stamp \
testC.cpp \
testC.h \
@@ -44,9 +40,17 @@ CLEANFILES += \
testC.cpp testC.h testC.inl testS.cpp testS.h testS.inl: test-stamp
test-stamp: $(srcdir)/test.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/test.idl
+ $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/test.idl
@touch $@
+
+noinst_HEADERS = \
+ test.idl
+
+## Makefile.Leader_Followers_Server.am
+
+if BUILD_EXCEPTIONS
+
noinst_PROGRAMS += server
server_CPPFLAGS = \
@@ -60,10 +64,6 @@ server_SOURCES = \
testC.cpp \
testS.cpp \
test_i.cpp \
- testC.h \
- testC.inl \
- testS.h \
- testS.inl \
test_i.h
server_LDADD = \
@@ -79,27 +79,6 @@ endif BUILD_EXCEPTIONS
if BUILD_EXCEPTIONS
-BUILT_SOURCES += \
- testC.cpp \
- testC.h \
- testC.inl \
- testS.h \
- testS.inl
-
-CLEANFILES += \
- test-stamp \
- testC.cpp \
- testC.h \
- testC.inl \
- testS.h \
- testS.inl
-
-testC.cpp testC.h testC.inl testS.h testS.inl: test-stamp
-
-test-stamp: $(srcdir)/test.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/test.idl
- @touch $@
-
noinst_PROGRAMS += client
client_CPPFLAGS = \
@@ -111,10 +90,7 @@ client_CPPFLAGS = \
client_SOURCES = \
client.cpp \
testC.cpp \
- testC.h \
- testC.inl \
- testS.h \
- testS.inl
+ test_i.h
client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO_Strategies.la \