summaryrefslogtreecommitdiff
path: root/TAO/tests/Portable_Interceptors/AMI/Makefile.am
diff options
context:
space:
mode:
authorjtc <jtc@ae88bc3d-4319-0410-8dbf-d08b4c9d3795>2006-12-23 02:11:32 +0000
committerjtc <jtc@ae88bc3d-4319-0410-8dbf-d08b4c9d3795>2006-12-23 02:11:32 +0000
commit327322656351ac412f572d92dbe64f9b671f534b (patch)
tree3b4ed173f116ca27c5eb8324472bcd4bc8cd2d61 /TAO/tests/Portable_Interceptors/AMI/Makefile.am
parente4df11f7cb935a8cc1394b76feac8348d918724f (diff)
downloadATCD-327322656351ac412f572d92dbe64f9b671f534b.tar.gz
ChangeLogTag: Sat Dec 23 02:01:44 UTC 2006 J.T. Conklin <jtc@acorntoolworks.com>
Diffstat (limited to 'TAO/tests/Portable_Interceptors/AMI/Makefile.am')
-rw-r--r--TAO/tests/Portable_Interceptors/AMI/Makefile.am58
1 files changed, 19 insertions, 39 deletions
diff --git a/TAO/tests/Portable_Interceptors/AMI/Makefile.am b/TAO/tests/Portable_Interceptors/AMI/Makefile.am
index 37fb4339104..c322b37f912 100644
--- a/TAO/tests/Portable_Interceptors/AMI/Makefile.am
+++ b/TAO/tests/Portable_Interceptors/AMI/Makefile.am
@@ -17,17 +17,14 @@ TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(T
TAO_ROOT = $(top_srcdir)
noinst_PROGRAMS =
-CLEANFILES =
-BUILT_SOURCES =
-## Makefile.PI_AMI_Client.am
+## Makefile.PI_AMI_Idl.am
if BUILD_AMI
if BUILD_CORBA_MESSAGING
if BUILD_EXCEPTIONS
-if BUILD_INTERCEPTORS
-BUILT_SOURCES += \
+BUILT_SOURCES = \
TestC.cpp \
TestC.h \
TestC.inl \
@@ -35,7 +32,7 @@ BUILT_SOURCES += \
TestS.h \
TestS.inl
-CLEANFILES += \
+CLEANFILES = \
Test-stamp \
TestC.cpp \
TestC.h \
@@ -50,6 +47,20 @@ Test-stamp: $(srcdir)/Test.idl $(TAO_IDL_DEP)
$(TAO_IDL) $(TAO_IDLFLAGS) -GC $(srcdir)/Test.idl
@touch $@
+noinst_HEADERS = \
+ Test.idl
+
+endif BUILD_EXCEPTIONS
+endif BUILD_CORBA_MESSAGING
+endif BUILD_AMI
+
+## Makefile.PI_AMI_Client.am
+
+if BUILD_AMI
+if BUILD_CORBA_MESSAGING
+if BUILD_EXCEPTIONS
+if BUILD_INTERCEPTORS
+
noinst_PROGRAMS += client
client_CPPFLAGS = \
@@ -67,11 +78,7 @@ client_SOURCES = \
client.cpp \
Client_Interceptor.h \
Client_ORBInitializer.h \
- Echo_Handler.h \
- TestC.h \
- TestC.inl \
- TestS.h \
- TestS.inl
+ Echo_Handler.h
client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
@@ -95,29 +102,6 @@ if BUILD_CORBA_MESSAGING
if BUILD_EXCEPTIONS
if BUILD_INTERCEPTORS
-BUILT_SOURCES += \
- TestC.cpp \
- TestC.h \
- TestC.inl \
- TestS.cpp \
- TestS.h \
- TestS.inl
-
-CLEANFILES += \
- Test-stamp \
- TestC.cpp \
- TestC.h \
- TestC.inl \
- TestS.cpp \
- TestS.h \
- TestS.inl
-
-TestC.cpp TestC.h TestC.inl TestS.cpp TestS.h TestS.inl: Test-stamp
-
-Test-stamp: $(srcdir)/Test.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) -GC $(srcdir)/Test.idl
- @touch $@
-
noinst_PROGRAMS += server
server_CPPFLAGS = \
@@ -135,11 +119,7 @@ server_SOURCES = \
server.cpp \
Echo.h \
Server_Interceptor.h \
- Server_ORBInitializer.h \
- TestC.h \
- TestC.inl \
- TestS.h \
- TestS.inl
+ Server_ORBInitializer.h
server_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO_PI_Server.la \