summaryrefslogtreecommitdiff
path: root/ace/Makefile.am
diff options
context:
space:
mode:
authorOssama Othman <ossama-othman@users.noreply.github.com>2004-01-23 03:58:53 +0000
committerOssama Othman <ossama-othman@users.noreply.github.com>2004-01-23 03:58:53 +0000
commit0b155932cb93b3cb2cc7d6f56cb9fa5271dcddd2 (patch)
treed2568f25f6cd86dda041eada9e250d62e3e68d6d /ace/Makefile.am
parent67e65690f3d25877202599b16372139d3f6c6586 (diff)
downloadATCD-0b155932cb93b3cb2cc7d6f56cb9fa5271dcddd2.tar.gz
ChangeLogTag:Thu Jan 22 19:57:59 2004 Ossama Othman <ossama@dre.vanderbilt.edu>
Diffstat (limited to 'ace/Makefile.am')
-rw-r--r--ace/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/ace/Makefile.am b/ace/Makefile.am
index d64298589db..563937b3d33 100644
--- a/ace/Makefile.am
+++ b/ace/Makefile.am
@@ -1360,6 +1360,8 @@ pkginclude_HEADERS = \
## needed anyway.
ACE_EXTRA_DIST = os_include
+## Automake recognized targets
+
dist-hook:
(cd $(srcdir); tar cf - $(ACE_EXTRA_DIST)) | (cd $(distdir); \
tar xfBp -)
@@ -1378,11 +1380,11 @@ clean-local:
## os_include subdirectory just for installation purposes seemed like
## overkill.
install-data-local:
- list=`find os_include -type d | grep -v CVS`; for p in $$list; do \
- $(mkdir_p) $$p; \
- files=`(cd $$p; echo *.h)`; \
+ list=`(cd $(srcdir); find os_include -type d | $(EGREP) -v CVS)`; for p in $$list; do \
+ $(mkdir_p) $(DESTDIR)$(pkgincludedir)/$$p; \
+ files=`(cd $(srcdir)/$$p; $(ECHO) *.h)`; \
test "$$files" != "*.h" && \
- (cd $$p; $(INSTALL_DATA) $$files $(DESTDIR)$(pkgincludedir)/$$p); \
+ (cd $(srcdir)/$$p; $(INSTALL_DATA) $$files $(DESTDIR)$(pkgincludedir)/$$p); \
done
## Clean up data installed by local targets.