summaryrefslogtreecommitdiff
path: root/ace/Makefile.am
diff options
context:
space:
mode:
authorOssama Othman <ossama-othman@users.noreply.github.com>1999-03-23 21:39:45 +0000
committerOssama Othman <ossama-othman@users.noreply.github.com>1999-03-23 21:39:45 +0000
commit88f7512582985ed419afd08432ab0ac0b00e9026 (patch)
tree5a0fcaa1c101ebe69523dba54e5334105b654559 /ace/Makefile.am
parent35fe54f3e40adee7e9b120963a20dcd732a2e8e9 (diff)
downloadATCD-88f7512582985ed419afd08432ab0ac0b00e9026.tar.gz
* ace/OS.h:
* ace/TLI.cpp: * ace/config-osf1-4.0.h: Removed all references to ACE_HAS_BROKEN_T_ERRNO and removed the definition of the _terrno() function from TLI.cpp since it isn't a standard TLI function (at least not the Steven's books that I've read). This also fixes a problem on Solaris that was causing an autoconfigured build of TLI.cpp to fail. * ace/Makefile.am: Make sure template source files get installed for all cases. Previously, they only got installed if the template source is required by the compiler. However, they are still needed by compilers that don't explicitly require template sources to be included in a file that references them.
Diffstat (limited to 'ace/Makefile.am')
-rw-r--r--ace/Makefile.am14
1 files changed, 3 insertions, 11 deletions
diff --git a/ace/Makefile.am b/ace/Makefile.am
index b6b6ee915b4..67873c97796 100644
--- a/ace/Makefile.am
+++ b/ace/Makefile.am
@@ -368,9 +368,7 @@ libACE_la_LDFLAGS = $(X_LIBS) \
# We also add any X libraries to the list.
libACE_la_LIBADD = $(X_PRE_LIBS) $(ACE_XLIBS) $(X_EXTRA_LIBS)
-## These are source files that are needed by the header files if the
-## ACE_TEMPLATES_REQUIRE_SOURCE or ACE_TEMPLATES_REQUIRE_PRAGMA
-## macro is defined.
+## These are template source files.
ACE_TEMPLATE_FILES = \
Acceptor.cpp \
Active_Map_Manager_T.cpp \
@@ -416,12 +414,6 @@ ACE_TEMPLATE_FILES = \
Typed_SV_Message.cpp \
Typed_SV_Message_Queue.cpp
-if TEMPLATES_REQUIRE_SOURCE
-TEMPLATE_FILES = $(ACE_TEMPLATE_FILES)
-else
-TEMPLATE_FILES =
-endif
-
## It would be good to remove pkgincludedir. However, we want to install
## headers in "$(prefix)/ace" not "$(prefix)/ACE" because the source files
## include files in the directory "ace." By default pkgincludedir would
@@ -814,8 +806,8 @@ pkginclude_HEADERS = \
iosfwd.h \
streams.h \
ws2tcpip.h \
- $(TEMPLATE_FILES)
-## Make sure config.h and $(TEMPLATE_FILES) are in the above header list!
+ $(ACE_TEMPLATE_FILES)
+## Make sure config.h and $(ACE_TEMPLATE_FILES) are in the above header list!
## Make sure the following get into the distribution
EXTRA_DIST = $(ACE_TEMPLATE_FILES)