summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorjtc <jtc@ae88bc3d-4319-0410-8dbf-d08b4c9d3795>2005-03-24 19:34:37 +0000
committerjtc <jtc@ae88bc3d-4319-0410-8dbf-d08b4c9d3795>2005-03-24 19:34:37 +0000
commitfacd041bee821995a9559d35ce2c5438a423b24e (patch)
treeb9f87792bd7f6283bb8fa97d1c7c3e996cff366d /configure.ac
parentc041b51088d071f6553c157526451bba6dc6309b (diff)
downloadATCD-facd041bee821995a9559d35ce2c5438a423b24e.tar.gz
ChangeLogTag: Thu Mar 24 11:26:58 2005 J.T. Conklin <jtc@acorntoolworks.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac97
1 files changed, 97 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 38ad4b78ce3..2b50d2da88b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1837,6 +1837,103 @@ else
ace_u_long_long_typedef_set=no
fi dnl test "$cross_compiling" != yes
+AC_CHECK_TYPE([int8_t],
+ [AC_DEFINE([ACE_HAS_INT8_T], 1,
+ [Define to 1 if the system has the type `int8_t'.])],
+ [],
+ [
+#ifndef ACE_LACKS_STDINT_H
+#include <stdint.h>
+#endif
+#ifndef ACE_LACKS_INTTYPES_H
+#include <inttypes.h>
+#endif])
+
+AC_CHECK_TYPE([uint8_t],
+ [AC_DEFINE([ACE_HAS_UINT8_T], 1,
+ [Define to 1 if the system has the type `uint8_t'.])],
+ [],
+ [
+#ifndef ACE_LACKS_STDINT_H
+#include <stdint.h>
+#endif
+#ifndef ACE_LACKS_INTTYPES_H
+#include <inttypes.h>
+#endif])
+
+AC_CHECK_TYPE([int16_t],
+ [AC_DEFINE([ACE_HAS_INT16_T], 1,
+ [Define to 1 if the system has the type `int16_t'.])],
+ [],
+ [
+#ifndef ACE_LACKS_STDINT_H
+#include <stdint.h>
+#endif
+#ifndef ACE_LACKS_INTTYPES_H
+#include <inttypes.h>
+#endif])
+
+AC_CHECK_TYPE([uint16_t],
+ [AC_DEFINE([ACE_HAS_UINT16_T], 1,
+ [Define to 1 if the system has the type `uint16_t'.])],
+ [],
+ [
+#ifndef ACE_LACKS_STDINT_H
+#include <stdint.h>
+#endif
+#ifndef ACE_LACKS_INTTYPES_H
+#include <inttypes.h>
+#endif])
+
+AC_CHECK_TYPE([int32_t],
+ [AC_DEFINE([ACE_HAS_INT32_T], 1,
+ [Define to 1 if the system has the type `int32_t'.])],
+ [],
+ [
+#ifndef ACE_LACKS_STDINT_H
+#include <stdint.h>
+#endif
+#ifndef ACE_LACKS_INTTYPES_H
+#include <inttypes.h>
+#endif])
+
+AC_CHECK_TYPE([uint32_t],
+ [AC_DEFINE([ACE_HAS_UINT32_T], 1,
+ [Define to 1 if the system has the type `uint32_t'.])],
+ [],
+ [
+#ifndef ACE_LACKS_STDINT_H
+#include <stdint.h>
+#endif
+#ifndef ACE_LACKS_INTTYPES_H
+#include <inttypes.h>
+#endif])
+
+AC_CHECK_TYPE([int64_t],
+ [AC_DEFINE([ACE_HAS_INT64_T], 1,
+ [Define to 1 if the system has the type `int64_t'.])],
+ [],
+ [
+#ifndef ACE_LACKS_STDINT_H
+#include <stdint.h>
+#endif
+#ifndef ACE_LACKS_INTTYPES_H
+#include <inttypes.h>
+#endif])
+
+AC_CHECK_TYPE([uint64_t],
+ [AC_DEFINE([ACE_HAS_UINT64_T], 1,
+ [Define to 1 if the system has the type `uint64_t'.])],
+ [],
+ [
+#ifndef ACE_LACKS_STDINT_H
+#include <stdint.h>
+#endif
+#ifndef ACE_LACKS_INTTYPES_H
+#include <inttypes.h>
+#endif])
+
+
dnl Other checks
ACE_VAR_TIMEZONE