summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSteve Huston <shuston@riverace.com>2004-06-28 20:35:55 +0000
committerSteve Huston <shuston@riverace.com>2004-06-28 20:35:55 +0000
commit3e6428c2ba28e25caae179514bb7906703b5d5c4 (patch)
treeb4e60e0a1437781833667333dd6392b1be58f42b /configure.ac
parent20018fe057e3876650db350a1fd8ac25b8f6e5a8 (diff)
downloadATCD-3e6428c2ba28e25caae179514bb7906703b5d5c4.tar.gz
ChangeLogTag:Mon Jun 28 16:34:29 2004 Steve Huston <shuston@riverace.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 28 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3f9455cf692..9f0d12051d1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,6 +37,13 @@ dnl Require GNU Autoconf 2.58 or better. Previous versions did not
dnl correctly support HP-UX.
AC_PREREQ([2.58])
+dnl Autoconf explicitly forbids patterns containing "_AC_". This causes
+dnl a problem when using MPC to generate the Automake ".am" files since
+dnl the "AC_CLD" project in ACE_wrappers/examples/C++NPv2 ends up having
+dnl a Makefile containing "NPv2_AC_CLD" in it, triggering the forbidden
+dnl "_AC_" pattern. Explicitly allow our pattern.
+m4_pattern_allow([NPv2_AC_CLD])
+
AC_CONFIG_SRCDIR([ace/ACE.cpp])
AC_CONFIG_AUX_DIR([aux_config])
@@ -3777,6 +3784,27 @@ AC_CHECK_FUNC([wcstoul],
,
[AC_DEFINE([ACE_LACKS_WCSTOUL])])
+if test "$ac_cv_func_wcstok" = yes; then
+dnl The wcstok() function varies with standards. Check which one we have.
+AC_MSG_CHECKING([for 2- or 3-param wcstok])
+AC_LINK_IFELSE([AC_LANG_PROGRAM(
+ [[
+#include <wchar.h>
+ ]],
+ [[
+ wchar_t str[] = L"junk";
+ const wchar_t delim[] = L"\t\n";
+ wchar_t *ptr;
+ wchar_t *p = wcstok (str, delim, &ptr);
+ ]])],
+ [
+ AC_DEFINE([ACE_HAS_3_PARAM_WCSTOK])
+ AC_MSG_RESULT([3])
+ ],
+ [
+ AC_MSG_RESULT([2])
+ ])
+fi dnl test "$ac_cv_func_wcstok" = yes
dnl Check for SYSV IPC functions
dnl