summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorOssama Othman <ossama-othman@users.noreply.github.com>2004-01-21 21:29:58 +0000
committerOssama Othman <ossama-othman@users.noreply.github.com>2004-01-21 21:29:58 +0000
commit3ffa9116223716bce04e610089649f4960ac0e06 (patch)
treef5000f2b1db862772c3529c384b74194f9834a98 /configure.ac
parentafab8bb457abbd9c147084c08253ab098da3b0d3 (diff)
downloadATCD-3ffa9116223716bce04e610089649f4960ac0e06.tar.gz
ChangeLogTag:Wed Jan 21 13:28:41 2004 Ossama Othman <ossama@dre.vanderbilt.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 603791fa225..f64ed66ba6b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7099,11 +7099,18 @@ ACE_CACHE_CHECK([if generated ACE configuration is usable],
typedef ACE_UINT64_TYPEDEF ACE_UINT64;
#endif /* ACE_UINT64_TYPEDEF */
-#include "ace/OS.cpp"
+// Include ".cpp" files instead of headers so that we can get a more
+// thorough test compile.
+#include "ace/Time_Value.cpp"
+#include "ace/Reactor.cpp"
],
[
ACE_Time_Value t = ACE_OS::gettimeofday ();
t++;
+
+ ACE_Reactor * r = ACE_Reactor::instance ();
+
+ (void) r->close ();
],
[
ace_cv_configuration_is_usable=yes