summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorjtc <jtc@ae88bc3d-4319-0410-8dbf-d08b4c9d3795>2004-08-10 14:23:25 +0000
committerjtc <jtc@ae88bc3d-4319-0410-8dbf-d08b4c9d3795>2004-08-10 14:23:25 +0000
commit6c4958704778f8d586100d36a6ea6d0064d7f665 (patch)
tree61f033bd6f672b93ca135b4e9ce9504f4cb77566 /configure.ac
parentf3e4f2acc9cb278f994a2843cf874b3928dbe582 (diff)
downloadATCD-6c4958704778f8d586100d36a6ea6d0064d7f665.tar.gz
ChangeLogTag: Tue Aug 10 06:52:47 2004 J.T. Conklin <jtc@acorntoolworks.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 1 insertions, 22 deletions
diff --git a/configure.ac b/configure.ac
index a925a651334..afb60f3617a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3087,28 +3087,17 @@ esac
ACE_CHECK_LACKS_FUNCS(access)
-dnl Temporarily select C as the test language to work around a bug in
-dnl some versions of Autoconf when C++ is selected as the test
-dnl language.
-AC_LANG_PUSH([C])
ACE_CHECK_LACKS_FUNCS(bsearch)
-AC_LANG_POP([C])
ACE_CHECK_HAS_FUNCS(clock_gettime)
-dnl Temporarily select C as the test language to work around a bug in
-dnl some versions of Autoconf when C++ is selected as the test
-dnl language.
-AC_LANG_PUSH([C])
ACE_CHECK_LACKS_FUNCS(qsort)
-AC_LANG_POP([C])
dnl ACE uses execv, execvp and execve, so we don't bother to check
dnl for the others (e.g. execl, execlp, execle)
AC_CHECK_FUNC(execv)
AC_CHECK_FUNC(execvp)
AC_CHECK_FUNC(execve)
-
if test "$ac_cv_func_execv" != yes &&
test "$ac_cv_func_execvp" != yes &&
test "$ac_cv_func_execve" != yes; then
@@ -3458,12 +3447,7 @@ AC_CHECK_FUNC([getpagesize],
ACE_CHECK_LACKS_FUNCS(msync mprotect mkfifo)
-dnl Temporarily select C as the test language to work around a bug in
-dnl some versions of Autoconf when C++ is selected as the test
-dnl language.
-AC_LANG_PUSH([C])
ACE_CHECK_LACKS_FUNCS(mkstemp mktemp)
-AC_LANG_POP([C])
ACE_CHECK_LACKS_FUNCS(madvise)
@@ -4193,12 +4177,7 @@ ACE_CHECK_HAS_FUNCS(sigwait)
dnl Check for reentrant functions
if test "$ace_user_enable_reentrant_funcs" = yes; then
- dnl Temporarily select C as the test language to work around a bug in
- dnl some versions of Autoconf when C++ is selected as the test
- dnl language.
- AC_LANG_PUSH([C])
- AC_CHECK_FUNC([rand_r],,)
- AC_LANG_POP([C])
+ AC_CHECK_FUNC([rand_r])
AC_CHECK_FUNC([strtok_r],
[