summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorOssama Othman <ossama-othman@users.noreply.github.com>2003-05-19 18:04:15 +0000
committerOssama Othman <ossama-othman@users.noreply.github.com>2003-05-19 18:04:15 +0000
commit92eef8323cf4a43764ae911b40369d536b0a44bf (patch)
tree932b4c7b66e34153fbc63b8c5c07b5308b94701d /configure.ac
parent3835fc831f73ab0c3d88b823cd54ee23a5543c60 (diff)
downloadATCD-92eef8323cf4a43764ae911b40369d536b0a44bf.tar.gz
ChangeLogTag:Mon May 19 11:03:31 2003 Ossama Othman <ossama@dre.vanderbilt.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 9 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 390c123cc8c..3888fc4c1d0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3199,13 +3199,14 @@ AC_CACHE_SAVE
dnl SECTION 10: checks for library functions
-
-AC_FUNC_ALLOCA
-if test "$ac_cv_header_alloca_h" = yes; then
- AC_DEFINE([ACE_HAS_ALLOCA_H])
-fi
-if test "$ac_cv_func_alloca_works" = yes; then
- AC_DEFINE([ACE_HAS_ALLOCA])
+if test "$ace_user_enable_alloca" = yes; then
+ AC_FUNC_ALLOCA
+ if test "$ac_cv_header_alloca_h" = yes; then
+ AC_DEFINE([ACE_HAS_ALLOCA_H])
+ fi
+ if test "$ac_cv_func_alloca_works" = yes; then
+ AC_DEFINE([ACE_HAS_ALLOCA])
+ fi
fi
dnl ACE should really have something for both the sys/mman.h header
@@ -3824,12 +3825,7 @@ dnl End check for SYSV IPC functions
AC_CHECK_FUNC([read_real_time],
[AC_DEFINE([ACE_HAS_AIX_HI_RES_TIMER])],)
-AC_CHECK_FUNC([shm_open],
- [
- AC_MSG_WARN([platform supports shm_open but shm_open support will not be])
- AC_MSG_WARN([enabled since ACE currently supports it only on LynxOS])
-dnl AC_DEFINE([ACE_HAS_SHM_OPEN])
- ],)
+AC_CHECK_FUNC([shm_open], [AC_DEFINE([ACE_HAS_SHM_OPEN])],)
AC_CHECK_FUNC([snprintf],
[AC_DEFINE([ACE_HAS_SNPRINTF])],)