summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorOssama Othman <ossama-othman@users.noreply.github.com>2004-05-01 01:29:04 +0000
committerOssama Othman <ossama-othman@users.noreply.github.com>2004-05-01 01:29:04 +0000
commit524e8ca5b56b09138b7f9df4fd47bb3172d5d4d3 (patch)
treee2befe07a9938f6589d1aa4b101eb7b937f5ae3b /configure.ac
parent9e882d6a06a741fd01eb999d50b9227558974aa5 (diff)
downloadATCD-524e8ca5b56b09138b7f9df4fd47bb3172d5d4d3.tar.gz
ChangeLogTag:Fri Apr 30 18:11:35 2004 Ossama Othman <ossama@dre.vanderbilt.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b8d7cafa559..bd87620511b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2172,11 +2172,13 @@ ACE_CACHE_CHECK([for ANSI C++ cast support],
])
],
[
- AC_DEFINE([ACE_HAS_ANSI_CASTS])
if test "$ace_cv_lib_rtti" != yes; then
AC_DEFINE([ACE_LACKS_RTTI])
fi
- ],)
+ ],
+ [
+ AC_MSG_ERROR([ACE requires a C++ compiler that supports ANSI C++ casts.])
+ ])
dnl Check for explicit C++ constructor support
ACE_CACHE_CHECK([for explicit C++ constructor support],