summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOssama Othman <ossama-othman@users.noreply.github.com>1999-07-14 21:42:09 +0000
committerOssama Othman <ossama-othman@users.noreply.github.com>1999-07-14 21:42:09 +0000
commitb7550823d1738c16df41e79f8f3e7d892b90f35a (patch)
tree81dca0d7a7e1362f317e62bf96479ccb7aa23782 /configure.in
parent322c9edc63f8652e24161f23ea0cfb66949d6255 (diff)
downloadATCD-b7550823d1738c16df41e79f8f3e7d892b90f35a.tar.gz
Minor ACE Configuration Project related updates and fixes.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in26
1 files changed, 22 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 02b6b27f610..405a4dd57e9 100644
--- a/configure.in
+++ b/configure.in
@@ -63,7 +63,7 @@ changequote(, )dnl
ACE_VERSION=`head -1 ${srcdir}/VERSION | sed 's/.*version \([0-9.]*\).*/\1/'`
changequote([, ])dnl
-AM_INIT_AUTOMAKE("$PACKAGE", "$ACE_VERSION", )
+AM_INIT_AUTOMAKE("$PACKAGE", "$ACE_VERSION", DUMMY)
dnl Generate a header file with all settings.
AM_CONFIG_HEADER(ace/config.h)
@@ -2511,13 +2511,28 @@ if test "$ac_cv_header_new" = yes &&
AC_TRY_COMPILE(
[
#include <memory>
+
+ template <class T>
+ class Foo
+ {
+ public:
+ Foo (void);
+ ~Foo (void);
+
+ T* bar (void) const { return this->bar_; }
+ private:
+ T* bar_;
+ };
],
[
+ Foo<int *> Baz = 0;
+
#ifdef ACE_USES_STD_NAMESPACE_FOR_STDCPP_LIB
- std::auto_ptr<int> Foo;
+ std::auto_ptr<Foo<int *> > Foobar;
#else
- auto_ptr<int> Foo;
+ auto_ptr<Foo<int *> > Foobar;
#endif
+ Foobar = Baz;
],
[
ace_cv_lib_auto_ptr_class=yes
@@ -2528,7 +2543,10 @@ if test "$ac_cv_header_new" = yes &&
],
[
AC_DEFINE(ACE_HAS_STANDARD_CPP_LIBRARY)
- ],)
+ ],
+ [
+ AC_DEFINE(ACE_LACKS_AUTO_PTR)
+ ])
fi
dnl Check for ANSI C++ cast support