summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOssama Othman <ossama-othman@users.noreply.github.com>1999-11-15 00:21:00 +0000
committerOssama Othman <ossama-othman@users.noreply.github.com>1999-11-15 00:21:00 +0000
commite0edeb7e3b539c1adb394462477ae34cecb8eb36 (patch)
tree924b2deb6ea9f8ff9e31b171889b640875e1fa90 /configure.in
parentac9226bf2d18ed9e9a45e43fd2266ef049667213 (diff)
downloadATCD-e0edeb7e3b539c1adb394462477ae34cecb8eb36.tar.gz
ChangeLogTag:Sun Nov 14 18:13:37 1999 Ossama Othman <othman@cs.wustl.edu>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 20 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 8f8fcce73b5..a56dec51667 100644
--- a/configure.in
+++ b/configure.in
@@ -1,7 +1,7 @@
dnl
dnl $Id$
-AC_REVISION($Revision 0.67 $)dnl
+AC_REVISION($Revision 0.68 $)dnl
dnl
dnl An autoconf script to automatically configure ACE.
@@ -41,6 +41,25 @@ AC_INIT(ace/ACE.cpp)
dnl Require GNU Autoconf 2.13 or better.
AC_PREREQ(2.13)
+dnl Add maintainer mode option to the option list.
+AM_MAINTAINER_MODE
+
+dnl Until autoconf support in ACE is complete, prevent this script
+dnl from running unless the user explictly forces the configure script
+dnl to run using the "--enable-maintainer-mode" configure script
+dnl option.
+if test $USE_MAINTAINER_MODE != yes; then
+ AC_MSG_ERROR([
+ ACE autoconf support is currently disabled by default since it is
+ still under development. Please use the stock ACE build procedure
+ detailed in the file \`ACE-INSTALL.html'.
+
+ If you wish to experiment with ACE's autoconf support then use the
+ \"--enable-maintainer-mode\" configure script option to enable
+ autoconf support. For more details see the file
+ \`ACE-configuration.txt'.])
+fi dnl test $USE_MAINTAINER_MODE != yes
+
dnl If we are configuring in a CVS controlled directory then don't
dnl continue any further. The idea is to prevent automatically
dnl generated files from being checked into the repository. This
@@ -184,9 +203,6 @@ dnl
dnl SECTION 2: Configure script command line options
dnl
-dnl Add maintainer mode option to the option list.
-AM_MAINTAINER_MODE
-
dnl Determine which subsets to build
dnl This is done using the autoconf "--enable-foobar" mechanism.
ACE_CHECK_SUBSETS