summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOssama Othman <ossama-othman@users.noreply.github.com>2000-02-10 18:31:18 +0000
committerOssama Othman <ossama-othman@users.noreply.github.com>2000-02-10 18:31:18 +0000
commitf2b38602ddfb6ae114e33d0bb2cba78fee8ae906 (patch)
treea47192ed51d0a97d64456bc44c6aa90810330db9 /configure.in
parent4148434dc06e1e23c538a58ad33e389b1ad375cd (diff)
downloadATCD-f2b38602ddfb6ae114e33d0bb2cba78fee8ae906.tar.gz
ChangeLogTag:Thu Feb 10 10:18:00 2000 Ossama Othman <ossama@uci.edu>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 38b79597e46..41bcec18334 100644
--- a/configure.in
+++ b/configure.in
@@ -3197,7 +3197,7 @@ Vector<void *> vpv;
])
], AC_DEFINE(ACE_HAS_STD_TEMPLATE_SPECIALIZATION),)
-if test $ace_cv_feature_cxx_std_template_specialization = yes; then
+if test "$ace_cv_feature_cxx_std_template_specialization" = yes; then
dnl Check if platform needs *standard* template method specialization
ACE_CACHE_CHECK(if platform needs standard template method specialization,
@@ -4380,9 +4380,14 @@ dnl name.
dnl these functions so both must be present in order to prevent
dnl ACE_LACKS_SETSCHED from being defined.
AC_CHECK_FUNC(sched_setscheduler, dnl
- AC_CHECK_FUNC(pthread_attr_setschedpolicy,,
+ [
+ AC_CHECK_FUNC(pthread_attr_setschedpolicy,,
AC_CHECK_FUNC(pthread_attr_setsched,,
- AC_DEFINE(ACE_LACKS_SETSCHED))))
+ AC_DEFINE(ACE_LACKS_SETSCHED)))
+ ],
+ [
+ AC_DEFINE(ACE_LACKS_SETSCHED)
+ ])
AC_CHECK_FUNC(pthread_attr_setscope, dnl
,