summaryrefslogtreecommitdiff
path: root/ACE/ACEXML/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ACE/ACEXML/tests/Makefile.am')
-rw-r--r--ACE/ACEXML/tests/Makefile.am222
1 files changed, 0 insertions, 222 deletions
diff --git a/ACE/ACEXML/tests/Makefile.am b/ACE/ACEXML/tests/Makefile.am
deleted file mode 100644
index e8f43fdc317..00000000000
--- a/ACE/ACEXML/tests/Makefile.am
+++ /dev/null
@@ -1,222 +0,0 @@
-## Process this file with automake to create Makefile.in
-##
-## $Id$
-##
-## This file was generated by MPC. Any changes made directly to
-## this file will be lost the next time it is generated.
-##
-## MPC Command:
-## ./bin/mwc.pl -type automake -noreldefs ACE.mwc
-
-ACE_BUILDDIR = $(top_builddir)
-ACE_ROOT = $(top_srcdir)
-
-SUBDIRS = \
- . \
- util
-
-noinst_PROGRAMS =
-
-## Makefile.ContentHandler_Test.am
-
-if BUILD_ACEXML
-if !BUILD_ACE_FOR_TAO
-
-noinst_PROGRAMS += ContentHandler_Test
-
-ContentHandler_Test_CPPFLAGS = \
- -I$(ACE_ROOT) \
- -I$(ACE_BUILDDIR) \
- -I$(ACE_ROOT)/ACEXML/common
-
-if BUILD_ZLIB
-if BUILD_ZZIP
-ContentHandler_Test_CPPFLAGS += \
- $(ACE_ZZIP_CPPFLAGS) \
- $(ACE_ZLIB_CPPFLAGS)
-endif BUILD_ZZIP
-endif BUILD_ZLIB
-
-ContentHandler_Test_SOURCES = \
- ContentHandler_Test.cpp
-
-ContentHandler_Test_LDFLAGS =
-
-if BUILD_ZLIB
-if BUILD_ZZIP
-ContentHandler_Test_LDFLAGS += \
- $(ACE_ZZIP_LDFLAGS) \
- $(ACE_ZLIB_LDFLAGS)
-endif BUILD_ZZIP
-endif BUILD_ZLIB
-
-ContentHandler_Test_LDADD = \
- $(ACE_BUILDDIR)/ACEXML/parser/parser/libACEXML_Parser.la \
- $(ACE_BUILDDIR)/ACEXML/common/libACEXML.la \
- $(ACE_BUILDDIR)/ace/libACE.la
-
-if BUILD_ZLIB
-if BUILD_ZZIP
-ContentHandler_Test_LDADD += \
- $(ACE_ZZIP_LIBS) \
- $(ACE_ZLIB_LIBS)
-endif BUILD_ZZIP
-endif BUILD_ZLIB
-
-endif !BUILD_ACE_FOR_TAO
-endif BUILD_ACEXML
-
-## Makefile.HttpCharStream_Test.am
-
-if BUILD_ACEXML
-if !BUILD_ACE_FOR_TAO
-
-noinst_PROGRAMS += HttpCharStream_Test
-
-HttpCharStream_Test_CPPFLAGS = \
- -I$(ACE_ROOT) \
- -I$(ACE_BUILDDIR) \
- -I$(ACE_ROOT)/ACEXML/common
-
-if BUILD_ZLIB
-if BUILD_ZZIP
-HttpCharStream_Test_CPPFLAGS += \
- $(ACE_ZZIP_CPPFLAGS) \
- $(ACE_ZLIB_CPPFLAGS)
-endif BUILD_ZZIP
-endif BUILD_ZLIB
-
-HttpCharStream_Test_SOURCES = \
- HttpCharStream_Test.cpp
-
-HttpCharStream_Test_LDFLAGS =
-
-if BUILD_ZLIB
-if BUILD_ZZIP
-HttpCharStream_Test_LDFLAGS += \
- $(ACE_ZZIP_LDFLAGS) \
- $(ACE_ZLIB_LDFLAGS)
-endif BUILD_ZZIP
-endif BUILD_ZLIB
-
-HttpCharStream_Test_LDADD = \
- $(ACE_BUILDDIR)/ACEXML/parser/parser/libACEXML_Parser.la \
- $(ACE_BUILDDIR)/ACEXML/common/libACEXML.la \
- $(ACE_BUILDDIR)/ace/libACE.la
-
-if BUILD_ZLIB
-if BUILD_ZZIP
-HttpCharStream_Test_LDADD += \
- $(ACE_ZZIP_LIBS) \
- $(ACE_ZLIB_LIBS)
-endif BUILD_ZZIP
-endif BUILD_ZLIB
-
-endif !BUILD_ACE_FOR_TAO
-endif BUILD_ACEXML
-
-## Makefile.NamespaceSupport_Test.am
-
-if BUILD_ACEXML
-if !BUILD_ACE_FOR_TAO
-
-noinst_PROGRAMS += NamespaceSupport_Test
-
-NamespaceSupport_Test_CPPFLAGS = \
- -I$(ACE_ROOT) \
- -I$(ACE_BUILDDIR) \
- -I$(ACE_ROOT)/ACEXML/common
-
-if BUILD_ZLIB
-if BUILD_ZZIP
-NamespaceSupport_Test_CPPFLAGS += \
- $(ACE_ZZIP_CPPFLAGS) \
- $(ACE_ZLIB_CPPFLAGS)
-endif BUILD_ZZIP
-endif BUILD_ZLIB
-
-NamespaceSupport_Test_SOURCES = \
- NamespaceSupport_Test.cpp
-
-NamespaceSupport_Test_LDFLAGS =
-
-if BUILD_ZLIB
-if BUILD_ZZIP
-NamespaceSupport_Test_LDFLAGS += \
- $(ACE_ZZIP_LDFLAGS) \
- $(ACE_ZLIB_LDFLAGS)
-endif BUILD_ZZIP
-endif BUILD_ZLIB
-
-NamespaceSupport_Test_LDADD = \
- $(ACE_BUILDDIR)/ACEXML/parser/parser/libACEXML_Parser.la \
- $(ACE_BUILDDIR)/ACEXML/common/libACEXML.la \
- $(ACE_BUILDDIR)/ace/libACE.la
-
-if BUILD_ZLIB
-if BUILD_ZZIP
-NamespaceSupport_Test_LDADD += \
- $(ACE_ZZIP_LIBS) \
- $(ACE_ZLIB_LIBS)
-endif BUILD_ZZIP
-endif BUILD_ZLIB
-
-endif !BUILD_ACE_FOR_TAO
-endif BUILD_ACEXML
-
-## Makefile.Transcoder_Test.am
-
-if BUILD_ACEXML
-if !BUILD_ACE_FOR_TAO
-
-noinst_PROGRAMS += Transcoder_Test
-
-Transcoder_Test_CPPFLAGS = \
- -I$(ACE_ROOT) \
- -I$(ACE_BUILDDIR) \
- -I$(ACE_ROOT)/ACEXML/common
-
-if BUILD_ZLIB
-if BUILD_ZZIP
-Transcoder_Test_CPPFLAGS += \
- $(ACE_ZZIP_CPPFLAGS) \
- $(ACE_ZLIB_CPPFLAGS)
-endif BUILD_ZZIP
-endif BUILD_ZLIB
-
-Transcoder_Test_SOURCES = \
- Transcoder_Test.cpp
-
-Transcoder_Test_LDFLAGS =
-
-if BUILD_ZLIB
-if BUILD_ZZIP
-Transcoder_Test_LDFLAGS += \
- $(ACE_ZZIP_LDFLAGS) \
- $(ACE_ZLIB_LDFLAGS)
-endif BUILD_ZZIP
-endif BUILD_ZLIB
-
-Transcoder_Test_LDADD = \
- $(ACE_BUILDDIR)/ACEXML/parser/parser/libACEXML_Parser.la \
- $(ACE_BUILDDIR)/ACEXML/common/libACEXML.la \
- $(ACE_BUILDDIR)/ace/libACE.la
-
-if BUILD_ZLIB
-if BUILD_ZZIP
-Transcoder_Test_LDADD += \
- $(ACE_ZZIP_LIBS) \
- $(ACE_ZLIB_LIBS)
-endif BUILD_ZZIP
-endif BUILD_ZLIB
-
-endif !BUILD_ACE_FOR_TAO
-endif BUILD_ACEXML
-
-## Clean up template repositories, etc.
-clean-local:
- -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
- -rm -f gcctemp.c gcctemp so_locations *.ics
- -rm -rf cxx_repository ptrepository ti_files
- -rm -rf templateregistry ir.out
- -rm -rf ptrepository SunWS_cache Templates.DB