summaryrefslogtreecommitdiff
path: root/ACE/ASNMP/asnmp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ACE/ASNMP/asnmp/Makefile.am')
-rw-r--r--ACE/ASNMP/asnmp/Makefile.am66
1 files changed, 66 insertions, 0 deletions
diff --git a/ACE/ASNMP/asnmp/Makefile.am b/ACE/ASNMP/asnmp/Makefile.am
new file mode 100644
index 00000000000..71347a6d858
--- /dev/null
+++ b/ACE/ASNMP/asnmp/Makefile.am
@@ -0,0 +1,66 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## /acebuilds/ACE_wrappers-repository/bin/mwc.pl -include /acebuilds/MPC/config -include /acebuilds/MPC/templates -feature_file /acebuilds/ACE_wrappers-repository/local.features -noreldefs -type automake -exclude build,Kokyu
+
+ACE_BUILDDIR = $(top_builddir)
+ACE_ROOT = $(top_srcdir)
+
+## Makefile.asnmp_lib.am
+
+noinst_LTLIBRARIES = libasnmp.la
+
+libasnmp_la_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(ACE_ROOT)/ASNMP \
+ -DASNMP_BUILD_DLL
+
+libasnmp_la_SOURCES = \
+ address.cpp \
+ asn1.cpp \
+ counter.cpp \
+ ctr64.cpp \
+ gauge.cpp \
+ integer.cpp \
+ octet.cpp \
+ oid.cpp \
+ pdu.cpp \
+ sagent.cpp \
+ snmp.cpp \
+ target.cpp \
+ timetick.cpp \
+ transaction.cpp \
+ vb.cpp \
+ wpdu.cpp
+
+noinst_HEADERS = \
+ address.h \
+ asn1.h \
+ counter.h \
+ ctr64.h \
+ gauge.h \
+ integer.h \
+ octet.h \
+ oid.h \
+ pdu.h \
+ sagent.h \
+ snmp.h \
+ target.h \
+ timetick.h \
+ transaction.h \
+ vb.h \
+ wpdu.h
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB