summaryrefslogtreecommitdiff
path: root/ACE/ASNMP/examples/trap/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ACE/ASNMP/examples/trap/Makefile.am')
-rw-r--r--ACE/ASNMP/examples/trap/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/ACE/ASNMP/examples/trap/Makefile.am b/ACE/ASNMP/examples/trap/Makefile.am
new file mode 100644
index 00000000000..a60adce7d30
--- /dev/null
+++ b/ACE/ASNMP/examples/trap/Makefile.am
@@ -0,0 +1,41 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ./bin/mwc.pl -type automake -noreldefs ACE.mwc
+
+ACE_BUILDDIR = $(top_builddir)
+ACE_ROOT = $(top_srcdir)
+
+
+## Makefile.asnmp_example_trap.am
+
+if !BUILD_USES_WCHAR
+
+noinst_PROGRAMS = trap
+
+trap_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(ACE_ROOT)/ASNMP
+
+trap_SOURCES = \
+ trap.cpp
+
+trap_LDADD = \
+ $(top_builddir)/ASNMP/asnmp/libasnmp.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif !BUILD_USES_WCHAR
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB