summaryrefslogtreecommitdiff
path: root/ACE/TAO/examples/Logging/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ACE/TAO/examples/Logging/Makefile.am')
-rw-r--r--ACE/TAO/examples/Logging/Makefile.am123
1 files changed, 123 insertions, 0 deletions
diff --git a/ACE/TAO/examples/Logging/Makefile.am b/ACE/TAO/examples/Logging/Makefile.am
new file mode 100644
index 00000000000..6ee689e1b9c
--- /dev/null
+++ b/ACE/TAO/examples/Logging/Makefile.am
@@ -0,0 +1,123 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
+
+ACE_BUILDDIR = $(top_builddir)/..
+ACE_ROOT = $(top_srcdir)/..
+TAO_BUILDDIR = $(top_builddir)
+TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/ace_gperf
+TAO_ROOT = $(top_srcdir)
+
+noinst_PROGRAMS =
+
+## Makefile.Logging_IDL.am
+
+BUILT_SOURCES = \
+ LoggerC.cpp \
+ LoggerC.h \
+ LoggerC.inl \
+ LoggerS.cpp \
+ LoggerS.h \
+ LoggerS.inl
+
+CLEANFILES = \
+ Logger-stamp \
+ LoggerC.cpp \
+ LoggerC.h \
+ LoggerC.inl \
+ LoggerS.cpp \
+ LoggerS.h \
+ LoggerS.inl
+
+LoggerC.cpp LoggerC.h LoggerC.inl LoggerS.cpp LoggerS.h LoggerS.inl: Logger-stamp
+
+Logger-stamp: $(srcdir)/Logger.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/Logger.idl
+ @touch $@
+
+noinst_HEADERS = \
+ Logger.idl
+
+## Makefile.Logging_Service.am
+
+if BUILD_EXCEPTIONS
+
+noinst_PROGRAMS += Logging_Service
+
+Logging_Service_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -I$(TAO_ROOT)/orbsvcs \
+ -I$(TAO_BUILDDIR)/orbsvcs
+
+Logging_Service_SOURCES = \
+ LoggerC.cpp \
+ LoggerS.cpp \
+ Logger_i.cpp \
+ Logging_Service.cpp \
+ Logging_Service_i.cpp \
+ Logger_i.h \
+ Logging_Service_i.h
+
+Logging_Service_LDADD = \
+ $(TAO_BUILDDIR)/tao/libTAO_Utils.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PI.la \
+ $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
+ $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif BUILD_EXCEPTIONS
+
+## Makefile.Logging_Test.am
+
+if BUILD_EXCEPTIONS
+
+noinst_PROGRAMS += Logging_Test
+
+Logging_Test_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -I$(TAO_ROOT)/orbsvcs \
+ -I$(TAO_BUILDDIR)/orbsvcs
+
+Logging_Test_SOURCES = \
+ LoggerC.cpp \
+ LoggerS.cpp \
+ Logging_Test.cpp \
+ Logging_Test_i.cpp \
+ Logging_Test_i.h
+
+Logging_Test_LDADD = \
+ $(TAO_BUILDDIR)/tao/libTAO_Utils.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PI.la \
+ $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
+ $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif BUILD_EXCEPTIONS
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB