summaryrefslogtreecommitdiff
path: root/ACE/TAO/tests/Bug_2417_Regression/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ACE/TAO/tests/Bug_2417_Regression/Makefile.am')
-rw-r--r--ACE/TAO/tests/Bug_2417_Regression/Makefile.am151
1 files changed, 151 insertions, 0 deletions
diff --git a/ACE/TAO/tests/Bug_2417_Regression/Makefile.am b/ACE/TAO/tests/Bug_2417_Regression/Makefile.am
new file mode 100644
index 00000000000..a4a12721c8f
--- /dev/null
+++ b/ACE/TAO/tests/Bug_2417_Regression/Makefile.am
@@ -0,0 +1,151 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
+
+ACE_BUILDDIR = $(top_builddir)/..
+ACE_ROOT = $(top_srcdir)/..
+TAO_BUILDDIR = $(top_builddir)
+TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/ace_gperf
+TAO_ROOT = $(top_srcdir)
+
+noinst_PROGRAMS =
+CLEANFILES =
+BUILT_SOURCES =
+
+## Makefile.Bug_2417_Regression_Idl.am
+
+if BUILD_EXCEPTIONS
+
+BUILT_SOURCES += \
+ publisherC.cpp \
+ publisherC.h \
+ publisherC.inl \
+ publisherS.cpp \
+ publisherS.h \
+ publisherS.inl
+
+CLEANFILES += \
+ publisher-stamp \
+ publisherC.cpp \
+ publisherC.h \
+ publisherC.inl \
+ publisherS.cpp \
+ publisherS.h \
+ publisherS.inl
+
+publisherC.cpp publisherC.h publisherC.inl publisherS.cpp publisherS.h publisherS.inl: publisher-stamp
+
+publisher-stamp: $(srcdir)/publisher.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/publisher.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ subscriberC.cpp \
+ subscriberC.h \
+ subscriberC.inl \
+ subscriberS.cpp \
+ subscriberS.h \
+ subscriberS.inl
+
+CLEANFILES += \
+ subscriber-stamp \
+ subscriberC.cpp \
+ subscriberC.h \
+ subscriberC.inl \
+ subscriberS.cpp \
+ subscriberS.h \
+ subscriberS.inl
+
+subscriberC.cpp subscriberC.h subscriberC.inl subscriberS.cpp subscriberS.h subscriberS.inl: subscriber-stamp
+
+subscriber-stamp: $(srcdir)/subscriber.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/subscriber.idl
+ @touch $@
+
+noinst_HEADERS = \
+ publisher.idl \
+ subscriber.idl
+
+endif BUILD_EXCEPTIONS
+
+## Makefile.Bug_2417_Regression_Client.am
+
+if BUILD_EXCEPTIONS
+if BUILD_THREADS
+
+noinst_PROGRAMS += client
+
+client_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR)
+
+client_SOURCES = \
+ client.cpp \
+ publisherC.cpp \
+ subscriberC.cpp \
+ subscriberS.cpp \
+ subscriber_impl.cpp \
+ subscriber_impl.h
+
+client_LDADD = \
+ $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif BUILD_THREADS
+endif BUILD_EXCEPTIONS
+
+## Makefile.Bug_2417_Regression_Server.am
+
+if BUILD_CORBA_MESSAGING
+if BUILD_EXCEPTIONS
+if BUILD_THREADS
+
+noinst_PROGRAMS += server
+
+server_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR)
+
+server_SOURCES = \
+ publisherC.cpp \
+ publisherS.cpp \
+ publisher_impl.cpp \
+ server.cpp \
+ subscriberC.cpp \
+ publisher_impl.h
+
+server_LDADD = \
+ $(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PI.la \
+ $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif BUILD_THREADS
+endif BUILD_EXCEPTIONS
+endif BUILD_CORBA_MESSAGING
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB