summaryrefslogtreecommitdiff
path: root/ACE/TAO/tests/POA/Explicit_Activation/Alt_Resources/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ACE/TAO/tests/POA/Explicit_Activation/Alt_Resources/Makefile.am')
-rw-r--r--ACE/TAO/tests/POA/Explicit_Activation/Alt_Resources/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/ACE/TAO/tests/POA/Explicit_Activation/Alt_Resources/Makefile.am b/ACE/TAO/tests/POA/Explicit_Activation/Alt_Resources/Makefile.am
new file mode 100644
index 00000000000..6418d4a8979
--- /dev/null
+++ b/ACE/TAO/tests/POA/Explicit_Activation/Alt_Resources/Makefile.am
@@ -0,0 +1,47 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
+
+ACE_BUILDDIR = $(top_builddir)/..
+ACE_ROOT = $(top_srcdir)/..
+TAO_BUILDDIR = $(top_builddir)
+TAO_ROOT = $(top_srcdir)
+
+
+## Makefile.Alt_Resource.am
+
+if BUILD_EXCEPTIONS
+if BUILD_WFMO
+
+noinst_LTLIBRARIES = libAlt_Resource_Factory.la
+
+libAlt_Resource_Factory_la_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -DAlt_Resource_Factory_BUILD_DLL
+
+libAlt_Resource_Factory_la_SOURCES = \
+ Resource_Factory.cpp
+
+noinst_HEADERS = \
+ Alt_Resource_Factory.h \
+ Resource_Factory.h
+
+endif BUILD_WFMO
+endif BUILD_EXCEPTIONS
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB