summaryrefslogtreecommitdiff
path: root/ACE/TAO/tests/TransportCurrent/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ACE/TAO/tests/TransportCurrent/lib/Makefile.am')
-rw-r--r--ACE/TAO/tests/TransportCurrent/lib/Makefile.am114
1 files changed, 114 insertions, 0 deletions
diff --git a/ACE/TAO/tests/TransportCurrent/lib/Makefile.am b/ACE/TAO/tests/TransportCurrent/lib/Makefile.am
new file mode 100644
index 00000000000..1c92e6dc390
--- /dev/null
+++ b/ACE/TAO/tests/TransportCurrent/lib/Makefile.am
@@ -0,0 +1,114 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
+
+ACE_BUILDDIR = $(top_builddir)/..
+ACE_ROOT = $(top_srcdir)/..
+TAO_BUILDDIR = $(top_builddir)
+TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/ace_gperf
+TAO_ROOT = $(top_srcdir)
+
+noinst_LTLIBRARIES =
+
+## Makefile.Current_Test_Lib_Idl.am
+
+BUILT_SOURCES = \
+ Current_TestC.cpp \
+ Current_TestC.h \
+ Current_TestC.inl \
+ Current_TestS.cpp \
+ Current_TestS.h \
+ Current_TestS.inl
+
+CLEANFILES = \
+ Current_Test-stamp \
+ Current_TestC.cpp \
+ Current_TestC.h \
+ Current_TestC.inl \
+ Current_TestS.cpp \
+ Current_TestS.h \
+ Current_TestS.inl
+
+Current_TestC.cpp Current_TestC.h Current_TestC.inl Current_TestS.cpp Current_TestS.h Current_TestS.inl: Current_Test-stamp
+
+Current_Test-stamp: $(srcdir)/Current_Test.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St -Wb,export_include=Current_Test_Export.h -Wb,export_macro=Current_Test_Export $(srcdir)/Current_Test.idl
+ @touch $@
+
+noinst_HEADERS = \
+ Current_Test.idl
+
+## Makefile.Current_Test_Lib_Client.am
+
+if BUILD_EXCEPTIONS
+if BUILD_INTERCEPTORS
+if BUILD_TRANSPORT_CURRENT
+
+noinst_LTLIBRARIES += libCurrent_Test_Lib_Client.la
+
+libCurrent_Test_Lib_Client_la_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -I. \
+ -DCURRENT_TEST_BUILD_DLL
+
+libCurrent_Test_Lib_Client_la_SOURCES = \
+ Client_ORBInitializer.cpp \
+ Client_Request_Interceptor.cpp \
+ Current_TestC.cpp
+
+noinst_HEADERS += \
+ Client_ORBInitializer.h \
+ Client_Request_Interceptor.h
+
+endif BUILD_TRANSPORT_CURRENT
+endif BUILD_INTERCEPTORS
+endif BUILD_EXCEPTIONS
+
+## Makefile.Current_Test_Lib_Server.am
+
+if BUILD_EXCEPTIONS
+if BUILD_INTERCEPTORS
+if BUILD_TRANSPORT_CURRENT
+
+noinst_LTLIBRARIES += libCurrent_Test_Lib_Server.la
+
+libCurrent_Test_Lib_Server_la_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -I. \
+ -DCURRENT_TEST_BUILD_DLL
+
+libCurrent_Test_Lib_Server_la_SOURCES = \
+ Current_TestC.cpp \
+ Current_TestS.cpp \
+ Server_ORBInitializer.cpp \
+ Server_Request_Interceptor.cpp
+
+noinst_HEADERS += \
+ Server_ORBInitializer.h \
+ Server_Request_Interceptor.h
+
+endif BUILD_TRANSPORT_CURRENT
+endif BUILD_INTERCEPTORS
+endif BUILD_EXCEPTIONS
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB