summaryrefslogtreecommitdiff
path: root/ACE/TAO/tests/Xt_Stopwatch/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ACE/TAO/tests/Xt_Stopwatch/Makefile.am')
-rw-r--r--ACE/TAO/tests/Xt_Stopwatch/Makefile.am176
1 files changed, 176 insertions, 0 deletions
diff --git a/ACE/TAO/tests/Xt_Stopwatch/Makefile.am b/ACE/TAO/tests/Xt_Stopwatch/Makefile.am
new file mode 100644
index 00000000000..8232b73765c
--- /dev/null
+++ b/ACE/TAO/tests/Xt_Stopwatch/Makefile.am
@@ -0,0 +1,176 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
+
+ACE_BUILDDIR = $(top_builddir)/..
+ACE_ROOT = $(top_srcdir)/..
+TAO_BUILDDIR = $(top_builddir)
+TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/ace_gperf
+TAO_ROOT = $(top_srcdir)
+
+noinst_PROGRAMS =
+CLEANFILES =
+BUILT_SOURCES =
+
+## Makefile.Xt_Stopwatch_Server.am
+
+if BUILD_ACE_XTREACTOR
+if BUILD_EXCEPTIONS
+if BUILD_MOTIF
+if BUILD_TAO_XTRESOURCE
+if BUILD_X11
+if BUILD_XT
+
+BUILT_SOURCES += \
+ testC.cpp \
+ testC.h \
+ testC.inl \
+ testS.cpp \
+ testS.h \
+ testS.inl
+
+CLEANFILES += \
+ test-stamp \
+ testC.cpp \
+ testC.h \
+ testC.inl \
+ testS.cpp \
+ testS.h \
+ testS.inl
+
+testC.cpp testC.h testC.inl testS.cpp testS.h testS.inl: test-stamp
+
+test-stamp: $(srcdir)/test.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/test.idl
+ @touch $@
+
+noinst_PROGRAMS += server
+
+server_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ $(ACE_X11_CPPFLAGS) \
+ $(ACE_XT_CPPFLAGS)
+
+server_SOURCES = \
+ Stopwatch_display.cpp \
+ server.cpp \
+ testC.cpp \
+ testS.cpp \
+ test_i.cpp \
+ timer.cpp \
+ Stopwatch_display.h \
+ testC.h \
+ testC.inl \
+ testS.h \
+ testS.inl \
+ test_i.h \
+ timer.h
+
+server_LDFLAGS = \
+ $(ACE_X11_LDFLAGS) $(ACE_XT_LDFLAGS)
+
+server_LDADD = \
+ $(TAO_BUILDDIR)/tao/libTAO_XtResource.la \
+ $(ACE_BUILDDIR)/ace/libACE_XtReactor.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la \
+ -lXm \
+ $(ACE_XT_LIBS) \
+ $(ACE_X11_LIBS)
+
+endif BUILD_XT
+endif BUILD_X11
+endif BUILD_TAO_XTRESOURCE
+endif BUILD_MOTIF
+endif BUILD_EXCEPTIONS
+endif BUILD_ACE_XTREACTOR
+
+## Makefile.Xt_Stopwatch_Client.am
+
+if BUILD_ACE_XTREACTOR
+if BUILD_EXCEPTIONS
+if BUILD_MOTIF
+if BUILD_TAO_XTRESOURCE
+if BUILD_X11
+if BUILD_XT
+
+BUILT_SOURCES += \
+ testC.cpp \
+ testC.h \
+ testC.inl \
+ testS.h \
+ testS.inl
+
+CLEANFILES += \
+ test-stamp \
+ testC.cpp \
+ testC.h \
+ testC.inl \
+ testS.h \
+ testS.inl
+
+testC.cpp testC.h testC.inl testS.h testS.inl: test-stamp
+
+test-stamp: $(srcdir)/test.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/test.idl
+ @touch $@
+
+noinst_PROGRAMS += client
+
+client_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ $(ACE_X11_CPPFLAGS) \
+ $(ACE_XT_CPPFLAGS)
+
+client_SOURCES = \
+ Control.cpp \
+ client.cpp \
+ testC.cpp \
+ Control.h \
+ testC.h \
+ testC.inl \
+ testS.h \
+ testS.inl
+
+client_LDFLAGS = \
+ $(ACE_X11_LDFLAGS) $(ACE_XT_LDFLAGS)
+
+client_LDADD = \
+ $(TAO_BUILDDIR)/tao/libTAO_XtResource.la \
+ $(ACE_BUILDDIR)/ace/libACE_XtReactor.la \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la \
+ -lXm \
+ $(ACE_XT_LIBS) \
+ $(ACE_X11_LIBS)
+
+endif BUILD_XT
+endif BUILD_X11
+endif BUILD_TAO_XTRESOURCE
+endif BUILD_MOTIF
+endif BUILD_EXCEPTIONS
+endif BUILD_ACE_XTREACTOR
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB