summaryrefslogtreecommitdiff
path: root/ACE/examples/Export/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ACE/examples/Export/Makefile.am')
-rw-r--r--ACE/examples/Export/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/ACE/examples/Export/Makefile.am b/ACE/examples/Export/Makefile.am
new file mode 100644
index 00000000000..671f716aaae
--- /dev/null
+++ b/ACE/examples/Export/Makefile.am
@@ -0,0 +1,52 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ./bin/mwc.pl -type automake -noreldefs ACE.mwc
+
+ACE_BUILDDIR = $(top_builddir)
+ACE_ROOT = $(top_srcdir)
+
+## Makefile.Export_Lib.am
+
+noinst_LTLIBRARIES = libExport_Lib.la
+
+libExport_Lib_la_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -DTEST_BUILD_DLL
+
+libExport_Lib_la_SOURCES = \
+ dll.cpp
+
+noinst_HEADERS = \
+ dll.h
+
+## Makefile.Export_Test.am
+
+noinst_PROGRAMS = test
+
+test_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR)
+
+test_SOURCES = \
+ test.cpp \
+ dll.h \
+ test_export.h
+
+test_LDADD = \
+ libExport_Lib.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB