summaryrefslogtreecommitdiff
path: root/ACE/examples/IPC_SAP/UPIPE_SAP/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ACE/examples/IPC_SAP/UPIPE_SAP/Makefile.am')
-rw-r--r--ACE/examples/IPC_SAP/UPIPE_SAP/Makefile.am76
1 files changed, 76 insertions, 0 deletions
diff --git a/ACE/examples/IPC_SAP/UPIPE_SAP/Makefile.am b/ACE/examples/IPC_SAP/UPIPE_SAP/Makefile.am
new file mode 100644
index 00000000000..90563ab7883
--- /dev/null
+++ b/ACE/examples/IPC_SAP/UPIPE_SAP/Makefile.am
@@ -0,0 +1,76 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ./bin/mwc.pl -type automake -noreldefs ACE.mwc
+
+ACE_BUILDDIR = $(top_builddir)
+ACE_ROOT = $(top_srcdir)
+
+noinst_PROGRAMS =
+
+## Makefile.UPIPE_SAP_Ex1.am
+
+if !BUILD_ACE_FOR_TAO
+
+noinst_PROGRAMS += ex1
+
+ex1_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR)
+
+ex1_SOURCES = \
+ ex1.cpp
+
+ex1_LDADD = \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif !BUILD_ACE_FOR_TAO
+
+## Makefile.UPIPE_SAP_Ex2.am
+
+if !BUILD_ACE_FOR_TAO
+
+noinst_PROGRAMS += ex2
+
+ex2_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR)
+
+ex2_SOURCES = \
+ ex2.cpp
+
+ex2_LDADD = \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif !BUILD_ACE_FOR_TAO
+
+## Makefile.UPIPE_SAP_Ex3.am
+
+if !BUILD_ACE_FOR_TAO
+
+noinst_PROGRAMS += ex3
+
+ex3_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR)
+
+ex3_SOURCES = \
+ ex3.cpp
+
+ex3_LDADD = \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif !BUILD_ACE_FOR_TAO
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB