summaryrefslogtreecommitdiff
path: root/ACE/examples/Naming/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ACE/examples/Naming/Makefile.am')
-rw-r--r--ACE/examples/Naming/Makefile.am94
1 files changed, 94 insertions, 0 deletions
diff --git a/ACE/examples/Naming/Makefile.am b/ACE/examples/Naming/Makefile.am
new file mode 100644
index 00000000000..a98ffabba50
--- /dev/null
+++ b/ACE/examples/Naming/Makefile.am
@@ -0,0 +1,94 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ./bin/mwc.pl -type automake -noreldefs ACE.mwc
+
+ACE_BUILDDIR = $(top_builddir)
+ACE_ROOT = $(top_srcdir)
+
+noinst_PROGRAMS =
+
+## Makefile.Naming_Multiple_Contexts.am
+
+if !BUILD_ACE_FOR_TAO
+
+noinst_PROGRAMS += multiple_contexts
+
+multiple_contexts_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR)
+
+multiple_contexts_SOURCES = \
+ test_multiple_contexts.cpp
+
+multiple_contexts_LDADD = \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif !BUILD_ACE_FOR_TAO
+
+## Makefile.Naming_Non_Existent.am
+
+if !BUILD_ACE_FOR_TAO
+
+noinst_PROGRAMS += non_existent
+
+non_existent_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR)
+
+non_existent_SOURCES = \
+ test_non_existent.cpp
+
+non_existent_LDADD = \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif !BUILD_ACE_FOR_TAO
+
+## Makefile.Naming_Open.am
+
+if !BUILD_ACE_FOR_TAO
+
+noinst_PROGRAMS += open
+
+open_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR)
+
+open_SOURCES = \
+ test_open.cpp
+
+open_LDADD = \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif !BUILD_ACE_FOR_TAO
+
+## Makefile.Naming_Writers.am
+
+if !BUILD_ACE_FOR_TAO
+
+noinst_PROGRAMS += writers
+
+writers_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR)
+
+writers_SOURCES = \
+ test_writers.cpp
+
+writers_LDADD = \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif !BUILD_ACE_FOR_TAO
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB