summaryrefslogtreecommitdiff
path: root/ACE/examples/QOS/Simple/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ACE/examples/QOS/Simple/Makefile.am')
-rw-r--r--ACE/examples/QOS/Simple/Makefile.am76
1 files changed, 76 insertions, 0 deletions
diff --git a/ACE/examples/QOS/Simple/Makefile.am b/ACE/examples/QOS/Simple/Makefile.am
new file mode 100644
index 00000000000..d86d7cd43eb
--- /dev/null
+++ b/ACE/examples/QOS/Simple/Makefile.am
@@ -0,0 +1,76 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## /acebuilds/ACE_wrappers-repository/bin/mwc.pl -include /acebuilds/MPC/config -include /acebuilds/MPC/templates -feature_file /acebuilds/ACE_wrappers-repository/local.features -noreldefs -type automake -exclude build,Kokyu
+
+ACE_BUILDDIR = $(top_builddir)
+ACE_ROOT = $(top_srcdir)
+
+noinst_PROGRAMS =
+
+## Makefile.QOS_Simple_Receiver.am
+
+if BUILD_QOS
+noinst_PROGRAMS += receiver
+
+receiver_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -DACE_HAS_QOS
+
+receiver_SOURCES = \
+ Fill_ACE_QoS.cpp \
+ QoS_Signal_Handler.cpp \
+ QoS_Util.cpp \
+ Receiver_QoS_Event_Handler.cpp \
+ receiver.cpp \
+ Fill_ACE_QoS.h \
+ QoS_Signal_Handler.h \
+ QoS_Util.h \
+ Receiver_QoS_Event_Handler.h
+
+receiver_LDADD = \
+ $(ACE_BUILDDIR)/ace/QoS/libACE_QoS.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif BUILD_QOS
+
+## Makefile.QOS_Simple_Sender.am
+
+if BUILD_QOS
+noinst_PROGRAMS += sender
+
+sender_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -DACE_HAS_QOS
+
+sender_SOURCES = \
+ Fill_ACE_QoS.cpp \
+ QoS_Signal_Handler.cpp \
+ QoS_Util.cpp \
+ Sender_QoS_Event_Handler.cpp \
+ sender.cpp \
+ Fill_ACE_QoS.h \
+ QoS_Signal_Handler.h \
+ QoS_Util.h \
+ Sender_QoS_Event_Handler.h
+
+sender_LDADD = \
+ $(ACE_BUILDDIR)/ace/QoS/libACE_QoS.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif BUILD_QOS
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB