summaryrefslogtreecommitdiff
path: root/ACE/netsvcs/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ACE/netsvcs/lib/Makefile.am')
-rw-r--r--ACE/netsvcs/lib/Makefile.am57
1 files changed, 57 insertions, 0 deletions
diff --git a/ACE/netsvcs/lib/Makefile.am b/ACE/netsvcs/lib/Makefile.am
new file mode 100644
index 00000000000..7614800dc4e
--- /dev/null
+++ b/ACE/netsvcs/lib/Makefile.am
@@ -0,0 +1,57 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## /acebuilds/ACE_wrappers-repository/bin/mwc.pl -include /acebuilds/MPC/config -include /acebuilds/MPC/templates -feature_file /acebuilds/ACE_wrappers-repository/local.features -noreldefs -type automake -exclude build,Kokyu
+
+ACE_BUILDDIR = $(top_builddir)
+ACE_ROOT = $(top_srcdir)
+
+
+## Makefile.netsvcs.am
+
+if !BUILD_ACE_FOR_TAO
+
+noinst_LTLIBRARIES = libnetsvcs.la
+
+libnetsvcs_la_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -DACE_NETSVCS_BUILD_DLL
+
+libnetsvcs_la_SOURCES = \
+ Base_Optimizer.cpp \
+ Client_Logging_Handler.cpp \
+ Log_Message_Receiver.cpp \
+ Name_Handler.cpp \
+ Server_Logging_Handler.cpp \
+ Server_Logging_Handler_T.cpp \
+ TS_Clerk_Handler.cpp \
+ TS_Server_Handler.cpp \
+ Token_Handler.cpp
+
+noinst_HEADERS = \
+ Base_Optimizer.h \
+ Client_Logging_Handler.h \
+ Log_Message_Receiver.h \
+ Name_Handler.h \
+ Server_Logging_Handler.h \
+ Server_Logging_Handler_T.cpp \
+ Server_Logging_Handler_T.h \
+ TS_Clerk_Handler.h \
+ TS_Server_Handler.h \
+ Token_Handler.h
+
+endif !BUILD_ACE_FOR_TAO
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB