summaryrefslogtreecommitdiff
path: root/ACE/performance-tests/Synch-Benchmarks/Base_Test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ACE/performance-tests/Synch-Benchmarks/Base_Test/Makefile.am')
-rw-r--r--ACE/performance-tests/Synch-Benchmarks/Base_Test/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/ACE/performance-tests/Synch-Benchmarks/Base_Test/Makefile.am b/ACE/performance-tests/Synch-Benchmarks/Base_Test/Makefile.am
new file mode 100644
index 00000000000..f5f4158d270
--- /dev/null
+++ b/ACE/performance-tests/Synch-Benchmarks/Base_Test/Makefile.am
@@ -0,0 +1,52 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ./bin/mwc.pl -type automake -noreldefs ACE.mwc
+
+ACE_BUILDDIR = $(top_builddir)
+ACE_ROOT = $(top_srcdir)
+
+
+## Makefile.Synch_Benchmarks_Base_Test.am
+
+if !BUILD_ACE_FOR_TAO
+
+noinst_LTLIBRARIES = libBase_Test.la
+
+libBase_Test_la_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(srcdir)/..
+
+libBase_Test_la_SOURCES = \
+ Baseline_Test.cpp \
+ base_test.cpp \
+ mutex_test.cpp
+
+../Synch_Lib:
+ mkdir -p ../Synch_Lib
+
+libBase_Test_la_DEPENDENCIES = \
+ ../Synch_Lib
+
+libBase_Test_la_LDFLAGS = \
+ -L../Synch_Lib
+
+noinst_HEADERS = \
+ Baseline_Test.h \
+ Baseline_Test.inl
+
+endif !BUILD_ACE_FOR_TAO
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB