summaryrefslogtreecommitdiff
path: root/ACE/performance-tests/Synch-Benchmarks/Perf_Test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ACE/performance-tests/Synch-Benchmarks/Perf_Test/Makefile.am')
-rw-r--r--ACE/performance-tests/Synch-Benchmarks/Perf_Test/Makefile.am73
1 files changed, 73 insertions, 0 deletions
diff --git a/ACE/performance-tests/Synch-Benchmarks/Perf_Test/Makefile.am b/ACE/performance-tests/Synch-Benchmarks/Perf_Test/Makefile.am
new file mode 100644
index 00000000000..ac4f8fc9a00
--- /dev/null
+++ b/ACE/performance-tests/Synch-Benchmarks/Perf_Test/Makefile.am
@@ -0,0 +1,73 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ./bin/mwc.pl -type automake -noreldefs ACE.mwc
+
+ACE_BUILDDIR = $(top_builddir)
+ACE_ROOT = $(top_srcdir)
+
+
+## Makefile.Synch_Benchmarks_Perf_Test.am
+
+if !BUILD_ACE_FOR_TAO
+
+noinst_LTLIBRARIES = libPerf_Test.la
+
+libPerf_Test_la_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(srcdir)/..
+
+libPerf_Test_la_SOURCES = \
+ Adaptive_Lock_Performance_Test_Base.cpp \
+ Benchmark_Performance.cpp \
+ Performance_Test.cpp \
+ Performance_Test_Options.cpp \
+ adaptive_mutex_test.cpp \
+ adaptive_recursive_lock_test.cpp \
+ adaptive_sema_test.cpp \
+ condb_test.cpp \
+ conds_test.cpp \
+ context_test.cpp \
+ guard_test.cpp \
+ memory_test.cpp \
+ mutex_test.cpp \
+ pipe_proc_test.cpp \
+ pipe_thr_test.cpp \
+ recursive_lock_test.cpp \
+ rwrd_test.cpp \
+ rwwr_test.cpp \
+ sema_test.cpp \
+ sysvsema_test.cpp \
+ token_test.cpp
+
+../Synch_Lib:
+ mkdir -p ../Synch_Lib
+
+libPerf_Test_la_DEPENDENCIES = \
+ ../Synch_Lib
+
+libPerf_Test_la_LDFLAGS = \
+ -L../Synch_Lib
+
+noinst_HEADERS = \
+ Adaptive_Lock_Performance_Test_Base.h \
+ Benchmark_Performance.h \
+ Performance_Test.h \
+ Performance_Test_Options.h \
+ Performance_Test_Options.inl
+
+endif !BUILD_ACE_FOR_TAO
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB