summaryrefslogtreecommitdiff
path: root/ACE/protocols/examples/RMCast/Send_Msg/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ACE/protocols/examples/RMCast/Send_Msg/Makefile.am')
-rw-r--r--ACE/protocols/examples/RMCast/Send_Msg/Makefile.am72
1 files changed, 72 insertions, 0 deletions
diff --git a/ACE/protocols/examples/RMCast/Send_Msg/Makefile.am b/ACE/protocols/examples/RMCast/Send_Msg/Makefile.am
new file mode 100644
index 00000000000..eb9a09d771f
--- /dev/null
+++ b/ACE/protocols/examples/RMCast/Send_Msg/Makefile.am
@@ -0,0 +1,72 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ./bin/mwc.pl -type automake -noreldefs ACE.mwc
+
+ACE_BUILDDIR = $(top_builddir)
+ACE_ROOT = $(top_srcdir)
+
+noinst_PROGRAMS =
+
+## Makefile.Send_Msg_Receiver.am
+
+if BUILD_EXCEPTIONS
+if BUILD_THREADS
+if !BUILD_ACE_FOR_TAO
+
+noinst_PROGRAMS += receiver
+
+receiver_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(ACE_ROOT)/protocols
+
+receiver_SOURCES = \
+ Receiver.cpp \
+ Protocol.h
+
+receiver_LDADD = \
+ $(ACE_BUILDDIR)/protocols/ace/RMCast/libACE_RMCast.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif !BUILD_ACE_FOR_TAO
+endif BUILD_THREADS
+endif BUILD_EXCEPTIONS
+
+## Makefile.Send_Msg_Sender.am
+
+if BUILD_EXCEPTIONS
+if BUILD_THREADS
+if !BUILD_ACE_FOR_TAO
+
+noinst_PROGRAMS += sender
+
+sender_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(ACE_ROOT)/protocols
+
+sender_SOURCES = \
+ Sender.cpp \
+ Protocol.h
+
+sender_LDADD = \
+ $(ACE_BUILDDIR)/protocols/ace/RMCast/libACE_RMCast.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif !BUILD_ACE_FOR_TAO
+endif BUILD_THREADS
+endif BUILD_EXCEPTIONS
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB