summaryrefslogtreecommitdiff
path: root/ACEXML/parser/parser/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ACEXML/parser/parser/Makefile.am')
-rw-r--r--ACEXML/parser/parser/Makefile.am58
1 files changed, 58 insertions, 0 deletions
diff --git a/ACEXML/parser/parser/Makefile.am b/ACEXML/parser/parser/Makefile.am
new file mode 100644
index 00000000000..3f50136debf
--- /dev/null
+++ b/ACEXML/parser/parser/Makefile.am
@@ -0,0 +1,58 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## /acebuilds/ACE_wrappers-repository/bin/mwc.pl -include /acebuilds/MPC/config -include /acebuilds/MPC/templates -feature_file /acebuilds/ACE_wrappers-repository/local.features -noreldefs -type automake -exclude build,Kokyu
+
+includedir = @includedir@/ACEXML/parser/parser
+pkgconfigdatadir = ${prefix}/lib/pkgconfig
+
+ACE_BUILDDIR = $(top_builddir)
+ACE_ROOT = $(top_srcdir)
+
+## Makefile.ACEXML_Parser.am
+lib_LTLIBRARIES = libACEXML_Parser.la
+
+libACEXML_Parser_la_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -DACEXML_PARSER_BUILD_DLL
+
+libACEXML_Parser_la_SOURCES = \
+ Entity_Manager.cpp \
+ Parser.cpp \
+ ParserContext.cpp \
+ ParserInternals.cpp
+
+libACEXML_Parser_la_LDFLAGS = \
+ -version-number @ACE_MAJOR@:@ACE_MINOR@:@ACE_BETA@
+
+libACEXML_Parser_la_LIBADD = \
+ $(top_builddir)/ACEXML/common/libACEXML.la $(top_builddir)/ace/libACE.la
+
+nobase_include_HEADERS = \
+ Entity_Manager.h \
+ Parser.h \
+ ParserContext.h \
+ ParserInternals.h \
+ Parser_export.h \
+ Entity_Manager.i \
+ Parser.i \
+ ParserContext.inl
+
+pkgconfigdata_DATA = ACEXML_Parser.pc
+
+ACEXML_Parser.pc: ${top_builddir}/config.status ${srcdir}/ACEXML_Parser.pc.in
+ ${top_builddir}/config.status --file $@:${srcdir}/ACEXML_Parser.pc.in
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB