summaryrefslogtreecommitdiff
path: root/ACEXML/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ACEXML/tests/Makefile.am')
-rw-r--r--ACEXML/tests/Makefile.am93
1 files changed, 93 insertions, 0 deletions
diff --git a/ACEXML/tests/Makefile.am b/ACEXML/tests/Makefile.am
new file mode 100644
index 00000000000..3a6e7a9df21
--- /dev/null
+++ b/ACEXML/tests/Makefile.am
@@ -0,0 +1,93 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## /acebuilds/ACE_wrappers-repository/bin/mwc.pl -include /acebuilds/MPC/config -include /acebuilds/MPC/templates -feature_file /acebuilds/ACE_wrappers-repository/local.features -noreldefs -type automake -exclude build,Kokyu
+
+ACE_BUILDDIR = $(top_builddir)
+ACE_ROOT = $(top_srcdir)
+
+noinst_PROGRAMS =
+## Makefile.ContentHandler_Test.am
+
+if BUILD_ACEXML
+noinst_PROGRAMS += ContentHandler_Test
+
+ContentHandler_Test_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(ACE_ROOT)/ACEXML/common
+
+ContentHandler_Test_SOURCES = \
+ ContentHandler_Test.cpp
+
+ContentHandler_Test_LDADD = \
+ $(top_builddir)/ACEXML/parser/parser/libACEXML_Parser.la $(top_builddir)/ACEXML/common/libACEXML.la $(top_builddir)/ace/libACE.la
+
+endif BUILD_ACEXML
+
+## Makefile.HttpCharStream_Test.am
+
+if BUILD_ACEXML
+noinst_PROGRAMS += HttpCharStream_Test
+
+HttpCharStream_Test_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(ACE_ROOT)/ACEXML/common
+
+HttpCharStream_Test_SOURCES = \
+ HttpCharStream_Test.cpp
+
+HttpCharStream_Test_LDADD = \
+ $(top_builddir)/ACEXML/parser/parser/libACEXML_Parser.la $(top_builddir)/ACEXML/common/libACEXML.la $(top_builddir)/ace/libACE.la
+
+endif BUILD_ACEXML
+
+## Makefile.NamespaceSupport_Test.am
+
+if BUILD_ACEXML
+noinst_PROGRAMS += NamespaceSupport_Test
+
+NamespaceSupport_Test_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(ACE_ROOT)/ACEXML/common
+
+NamespaceSupport_Test_SOURCES = \
+ NamespaceSupport_Test.cpp
+
+NamespaceSupport_Test_LDADD = \
+ $(top_builddir)/ACEXML/parser/parser/libACEXML_Parser.la $(top_builddir)/ACEXML/common/libACEXML.la $(top_builddir)/ace/libACE.la
+
+endif BUILD_ACEXML
+
+## Makefile.Transcoder_Test.am
+
+if BUILD_ACEXML
+noinst_PROGRAMS += Transcoder_Test
+
+Transcoder_Test_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(ACE_ROOT)/ACEXML/common
+
+Transcoder_Test_SOURCES = \
+ Transcoder_Test.cpp
+
+Transcoder_Test_LDADD = \
+ $(top_builddir)/ACEXML/parser/parser/libACEXML_Parser.la $(top_builddir)/ACEXML/common/libACEXML.la $(top_builddir)/ace/libACE.la
+
+endif BUILD_ACEXML
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB