summaryrefslogtreecommitdiff
path: root/TAO/docs/tutorials/Quoter/AMI/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/docs/tutorials/Quoter/AMI/Makefile.am')
-rw-r--r--TAO/docs/tutorials/Quoter/AMI/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/TAO/docs/tutorials/Quoter/AMI/Makefile.am b/TAO/docs/tutorials/Quoter/AMI/Makefile.am
index 8b2c868579f..06b7f62661a 100644
--- a/TAO/docs/tutorials/Quoter/AMI/Makefile.am
+++ b/TAO/docs/tutorials/Quoter/AMI/Makefile.am
@@ -13,7 +13,7 @@ ACE_ROOT = $(top_srcdir)/..
TAO_BUILDDIR = $(top_builddir)
TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
-TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
noinst_PROGRAMS =
@@ -22,7 +22,6 @@ noinst_PROGRAMS =
if BUILD_AMI
if BUILD_CORBA_MESSAGING
-if BUILD_EXCEPTIONS
BUILT_SOURCES = \
QuoterC.cpp \
@@ -47,10 +46,10 @@ Quoter-stamp: $(srcdir)/Quoter.idl $(TAO_IDL_DEP)
$(TAO_IDL) $(TAO_IDLFLAGS) -GC $(srcdir)/Quoter.idl
@touch $@
+
noinst_HEADERS = \
Quoter.idl
-endif BUILD_EXCEPTIONS
endif BUILD_CORBA_MESSAGING
endif BUILD_AMI