summaryrefslogtreecommitdiff
path: root/TAO/docs/tutorials/Quoter/RT_Event_Service/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/docs/tutorials/Quoter/RT_Event_Service/Makefile.am')
-rw-r--r--TAO/docs/tutorials/Quoter/RT_Event_Service/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/TAO/docs/tutorials/Quoter/RT_Event_Service/Makefile.am b/TAO/docs/tutorials/Quoter/RT_Event_Service/Makefile.am
index 5ebb6457432..73e5000bf36 100644
--- a/TAO/docs/tutorials/Quoter/RT_Event_Service/Makefile.am
+++ b/TAO/docs/tutorials/Quoter/RT_Event_Service/Makefile.am
@@ -6,7 +6,7 @@
## this file will be lost the next time it is generated.
##
## MPC Command:
-## ../bin/mwc.pl -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/config -include /home/jtc/ACE/ACE-autoconf/ACE_wrappers/TAO/../MPC/templates -type automake -noreldefs TAO.mwc
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
ACE_BUILDDIR = $(top_builddir)/..
ACE_ROOT = $(top_srcdir)/..
@@ -50,10 +50,14 @@ Quoter-stamp: $(srcdir)/Quoter.idl $(TAO_IDL_DEP)
@touch $@
+noinst_HEADERS = \
+ Quoter.idl
+
## Makefile.Quoter_RT_Event_Service_Client.am
if BUILD_CORBA_MESSAGING
if BUILD_EXCEPTIONS
+if !BUILD_ACE_FOR_TAO
if !BUILD_MINIMUM_CORBA
noinst_PROGRAMS += client
@@ -88,6 +92,7 @@ client_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif !BUILD_MINIMUM_CORBA
+endif !BUILD_ACE_FOR_TAO
endif BUILD_EXCEPTIONS
endif BUILD_CORBA_MESSAGING
@@ -95,6 +100,7 @@ endif BUILD_CORBA_MESSAGING
if BUILD_CORBA_MESSAGING
if BUILD_EXCEPTIONS
+if !BUILD_ACE_FOR_TAO
if !BUILD_MINIMUM_CORBA
noinst_PROGRAMS += server
@@ -132,6 +138,7 @@ server_LDADD = \
$(ACE_BUILDDIR)/ace/libACE.la
endif !BUILD_MINIMUM_CORBA
+endif !BUILD_ACE_FOR_TAO
endif BUILD_EXCEPTIONS
endif BUILD_CORBA_MESSAGING