summaryrefslogtreecommitdiff
path: root/TAO/examples/Buffered_Oneways/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/examples/Buffered_Oneways/Makefile.am')
-rw-r--r--TAO/examples/Buffered_Oneways/Makefile.am61
1 files changed, 48 insertions, 13 deletions
diff --git a/TAO/examples/Buffered_Oneways/Makefile.am b/TAO/examples/Buffered_Oneways/Makefile.am
index ab48864b8b6..596a38dd0b8 100644
--- a/TAO/examples/Buffered_Oneways/Makefile.am
+++ b/TAO/examples/Buffered_Oneways/Makefile.am
@@ -16,11 +16,15 @@ TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
+CLEANFILES =
noinst_PROGRAMS =
+BUILT_SOURCES =
-## Makefile.Buffered_Oneways_IDL.am
+## Makefile.Buffered_Oneways_Client.am
+
+if BUILD_CORBA_MESSAGING
-BUILT_SOURCES = \
+BUILT_SOURCES += \
testC.cpp \
testC.h \
testC.inl \
@@ -31,7 +35,7 @@ BUILT_SOURCES = \
testS_T.h \
testS_T.inl
-CLEANFILES = \
+CLEANFILES += \
test-stamp \
testC.cpp \
testC.h \
@@ -46,17 +50,9 @@ CLEANFILES = \
testC.cpp testC.h testC.inl testS.cpp testS.h testS.inl testS_T.cpp testS_T.h testS_T.inl: test-stamp
test-stamp: $(srcdir)/test.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/test.idl
+ $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/test.idl
@touch $@
-
-noinst_HEADERS = \
- test.idl
-
-## Makefile.Buffered_Oneways_Client.am
-
-if BUILD_CORBA_MESSAGING
-
noinst_PROGRAMS += client
client_CPPFLAGS = \
@@ -68,7 +64,12 @@ client_CPPFLAGS = \
client_SOURCES = \
client.cpp \
testC.cpp \
- test_i.h
+ testS.cpp \
+ testC.h \
+ testC.inl \
+ testS.h \
+ testS_T.h \
+ testS_T.inl
client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
@@ -86,6 +87,35 @@ endif BUILD_CORBA_MESSAGING
if BUILD_CORBA_MESSAGING
+BUILT_SOURCES += \
+ testC.cpp \
+ testC.h \
+ testC.inl \
+ testS.cpp \
+ testS.h \
+ testS.inl \
+ testS_T.cpp \
+ testS_T.h \
+ testS_T.inl
+
+CLEANFILES += \
+ test-stamp \
+ testC.cpp \
+ testC.h \
+ testC.inl \
+ testS.cpp \
+ testS.h \
+ testS.inl \
+ testS_T.cpp \
+ testS_T.h \
+ testS_T.inl
+
+testC.cpp testC.h testC.inl testS.cpp testS.h testS.inl testS_T.cpp testS_T.h testS_T.inl: test-stamp
+
+test-stamp: $(srcdir)/test.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/test.idl
+ @touch $@
+
noinst_PROGRAMS += server
server_CPPFLAGS = \
@@ -99,6 +129,11 @@ server_SOURCES = \
testC.cpp \
testS.cpp \
test_i.cpp \
+ testC.h \
+ testC.inl \
+ testS.h \
+ testS_T.h \
+ testS_T.inl \
test_i.h
server_LDADD = \