summaryrefslogtreecommitdiff
path: root/TAO/examples/CSD_Strategy/ThreadPool/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/examples/CSD_Strategy/ThreadPool/Makefile.am')
-rw-r--r--TAO/examples/CSD_Strategy/ThreadPool/Makefile.am94
1 files changed, 53 insertions, 41 deletions
diff --git a/TAO/examples/CSD_Strategy/ThreadPool/Makefile.am b/TAO/examples/CSD_Strategy/ThreadPool/Makefile.am
index 391bf5abc26..099b8e11e3c 100644
--- a/TAO/examples/CSD_Strategy/ThreadPool/Makefile.am
+++ b/TAO/examples/CSD_Strategy/ThreadPool/Makefile.am
@@ -13,12 +13,10 @@ ACE_ROOT = $(top_srcdir)/..
TAO_BUILDDIR = $(top_builddir)
TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
-TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
-noinst_PROGRAMS =
-
-## Makefile.CSD_Test_ThreadPool_Idl.am
+## Makefile.CSD_Test_ThreadPool_Server.am
BUILT_SOURCES = \
FooC.cpp \
@@ -40,43 +38,10 @@ CLEANFILES = \
FooC.cpp FooC.h FooC.inl FooS.cpp FooS.h FooS.inl: Foo-stamp
Foo-stamp: $(srcdir)/Foo.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/Foo.idl
+ $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/Foo.idl
@touch $@
-noinst_HEADERS = \
- Foo.idl
-
-## Makefile.CSD_Test_ThreadPool_Client.am
-
-if BUILD_EXCEPTIONS
-
-noinst_PROGRAMS += client_main
-
-client_main_CPPFLAGS = \
- -I$(ACE_ROOT) \
- -I$(ACE_BUILDDIR) \
- -I$(TAO_ROOT) \
- -I$(TAO_BUILDDIR)
-
-client_main_SOURCES = \
- ClientApp.cpp \
- FooC.cpp \
- client_main.cpp \
- ClientApp.h
-
-client_main_LDADD = \
- $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
- $(TAO_BUILDDIR)/tao/libTAO.la \
- $(ACE_BUILDDIR)/ace/libACE.la
-
-endif BUILD_EXCEPTIONS
-
-## Makefile.CSD_Test_ThreadPool_Server.am
-
-if BUILD_EXCEPTIONS
-if BUILD_THREADS
-
-noinst_PROGRAMS += server_main
+noinst_PROGRAMS = server_main
server_main_CPPFLAGS = \
-I$(ACE_ROOT) \
@@ -91,6 +56,10 @@ server_main_SOURCES = \
OrbShutdownTask.cpp \
ServerApp.cpp \
server_main.cpp \
+ FooC.h \
+ FooC.inl \
+ FooS.h \
+ FooS.inl \
Foo_i.h \
OrbShutdownTask.h \
ServerApp.h
@@ -105,8 +74,51 @@ server_main_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-endif BUILD_THREADS
-endif BUILD_EXCEPTIONS
+## Makefile.CSD_Test_ThreadPool_Client.am
+
+BUILT_SOURCES += \
+ FooC.cpp \
+ FooC.h \
+ FooC.inl \
+ FooS.h \
+ FooS.inl
+
+CLEANFILES += \
+ Foo-stamp \
+ FooC.cpp \
+ FooC.h \
+ FooC.inl \
+ FooS.h \
+ FooS.inl
+
+FooC.cpp FooC.h FooC.inl FooS.h FooS.inl: Foo-stamp
+
+Foo-stamp: $(srcdir)/Foo.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/Foo.idl
+ @touch $@
+
+noinst_PROGRAMS += client_main
+
+client_main_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR)
+
+client_main_SOURCES = \
+ ClientApp.cpp \
+ FooC.cpp \
+ client_main.cpp \
+ ClientApp.h \
+ FooC.h \
+ FooC.inl \
+ FooS.h \
+ FooS.inl
+
+client_main_LDADD = \
+ $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
## Clean up template repositories, etc.
clean-local: