summaryrefslogtreecommitdiff
path: root/TAO/examples/Event_Comm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/examples/Event_Comm/Makefile.am')
-rw-r--r--TAO/examples/Event_Comm/Makefile.am83
1 files changed, 75 insertions, 8 deletions
diff --git a/TAO/examples/Event_Comm/Makefile.am b/TAO/examples/Event_Comm/Makefile.am
index 4aeaf8ae4e3..8dc7b42f0fd 100644
--- a/TAO/examples/Event_Comm/Makefile.am
+++ b/TAO/examples/Event_Comm/Makefile.am
@@ -16,7 +16,7 @@ TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
-## Makefile.Event_Comm_IDL.am
+## Makefile.Event_Comm_Consumer.am
BUILT_SOURCES = \
Event_CommC.cpp \
@@ -44,15 +44,9 @@ CLEANFILES = \
Event_CommC.cpp Event_CommC.h Event_CommC.inl Event_CommS.cpp Event_CommS.h Event_CommS.inl Event_CommS_T.cpp Event_CommS_T.h Event_CommS_T.inl: Event_Comm-stamp
Event_Comm-stamp: $(srcdir)/Event_Comm.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/Event_Comm.idl
+ $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs $(srcdir)/Event_Comm.idl
@touch $@
-
-noinst_HEADERS = \
- Event_Comm.idl
-
-## Makefile.Event_Comm_Consumer.am
-
noinst_PROGRAMS = consumer
consumer_CPPFLAGS = \
@@ -72,6 +66,11 @@ consumer_SOURCES = \
consumer.cpp \
Consumer_Handler.h \
Consumer_Input_Handler.h \
+ Event_CommC.h \
+ Event_CommC.inl \
+ Event_CommS.h \
+ Event_CommS_T.h \
+ Event_CommS_T.inl \
Event_Comm_i.h
consumer_LDADD = \
@@ -83,6 +82,35 @@ consumer_LDADD = \
## Makefile.Event_Comm_Notifier.am
+BUILT_SOURCES += \
+ Event_CommC.cpp \
+ Event_CommC.h \
+ Event_CommC.inl \
+ Event_CommS.cpp \
+ Event_CommS.h \
+ Event_CommS.inl \
+ Event_CommS_T.cpp \
+ Event_CommS_T.h \
+ Event_CommS_T.inl
+
+CLEANFILES += \
+ Event_Comm-stamp \
+ Event_CommC.cpp \
+ Event_CommC.h \
+ Event_CommC.inl \
+ Event_CommS.cpp \
+ Event_CommS.h \
+ Event_CommS.inl \
+ Event_CommS_T.cpp \
+ Event_CommS_T.h \
+ Event_CommS_T.inl
+
+Event_CommC.cpp Event_CommC.h Event_CommC.inl Event_CommS.cpp Event_CommS.h Event_CommS.inl Event_CommS_T.cpp Event_CommS_T.h Event_CommS_T.inl: Event_Comm-stamp
+
+Event_Comm-stamp: $(srcdir)/Event_Comm.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs $(srcdir)/Event_Comm.idl
+ @touch $@
+
noinst_PROGRAMS += notifier
notifier_CPPFLAGS = \
@@ -99,6 +127,11 @@ notifier_SOURCES = \
Event_Comm_i.cpp \
Notifier_Server.cpp \
notifier.cpp \
+ Event_CommC.h \
+ Event_CommC.inl \
+ Event_CommS.h \
+ Event_CommS_T.h \
+ Event_CommS_T.inl \
Event_Comm_i.h \
Notifier_Server.h \
notifier.h
@@ -115,6 +148,35 @@ notifier_LDADD = \
## Makefile.Event_Comm_Supplier.am
+BUILT_SOURCES += \
+ Event_CommC.cpp \
+ Event_CommC.h \
+ Event_CommC.inl \
+ Event_CommS.cpp \
+ Event_CommS.h \
+ Event_CommS.inl \
+ Event_CommS_T.cpp \
+ Event_CommS_T.h \
+ Event_CommS_T.inl
+
+CLEANFILES += \
+ Event_Comm-stamp \
+ Event_CommC.cpp \
+ Event_CommC.h \
+ Event_CommC.inl \
+ Event_CommS.cpp \
+ Event_CommS.h \
+ Event_CommS.inl \
+ Event_CommS_T.cpp \
+ Event_CommS_T.h \
+ Event_CommS_T.inl
+
+Event_CommC.cpp Event_CommC.h Event_CommC.inl Event_CommS.cpp Event_CommS.h Event_CommS.inl Event_CommS_T.cpp Event_CommS_T.h Event_CommS_T.inl: Event_Comm-stamp
+
+Event_Comm-stamp: $(srcdir)/Event_Comm.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs $(srcdir)/Event_Comm.idl
+ @touch $@
+
noinst_PROGRAMS += supplier
supplier_CPPFLAGS = \
@@ -132,6 +194,11 @@ supplier_SOURCES = \
Notifier_Handler.cpp \
Supplier_Input_Handler.cpp \
supplier.cpp \
+ Event_CommC.h \
+ Event_CommC.inl \
+ Event_CommS.h \
+ Event_CommS_T.h \
+ Event_CommS_T.inl \
Event_Comm_i.h \
Notifier_Handler.h \
Supplier_Input_Handler.h \