summaryrefslogtreecommitdiff
path: root/TAO/examples/Kokyu_dsrt_schedulers/fp_example/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/examples/Kokyu_dsrt_schedulers/fp_example/Makefile.am')
-rw-r--r--TAO/examples/Kokyu_dsrt_schedulers/fp_example/Makefile.am71
1 files changed, 50 insertions, 21 deletions
diff --git a/TAO/examples/Kokyu_dsrt_schedulers/fp_example/Makefile.am b/TAO/examples/Kokyu_dsrt_schedulers/fp_example/Makefile.am
index 84b80fd2250..386c0449d09 100644
--- a/TAO/examples/Kokyu_dsrt_schedulers/fp_example/Makefile.am
+++ b/TAO/examples/Kokyu_dsrt_schedulers/fp_example/Makefile.am
@@ -16,47 +16,41 @@ TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
+CLEANFILES =
noinst_PROGRAMS =
+BUILT_SOURCES =
-## Makefile.fp_example_IDL.am
+## Makefile.fp_client.am
+
+if BUILD_RT_CORBA
-BUILT_SOURCES = \
+BUILT_SOURCES += \
testC.cpp \
testC.h \
testC.inl \
- testS.cpp \
testS.h \
testS.inl \
testS_T.cpp \
testS_T.h \
testS_T.inl
-CLEANFILES = \
+CLEANFILES += \
test-stamp \
testC.cpp \
testC.h \
testC.inl \
- testS.cpp \
testS.h \
testS.inl \
testS_T.cpp \
testS_T.h \
testS_T.inl
-testC.cpp testC.h testC.inl testS.cpp testS.h testS.inl testS_T.cpp testS_T.h testS_T.inl: test-stamp
+testC.cpp testC.h testC.inl testS.h testS.inl testS_T.cpp testS_T.h testS_T.inl: test-stamp
test-stamp: $(srcdir)/test.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/test.idl
+ $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/test.idl
@touch $@
-
-noinst_HEADERS = \
- test.idl
-
-## Makefile.fp_client.am
-
-if BUILD_RT_CORBA
-
noinst_PROGRAMS += fp_client
fp_client_CPPFLAGS = \
@@ -65,14 +59,16 @@ fp_client_CPPFLAGS = \
-I$(TAO_ROOT) \
-I$(TAO_BUILDDIR) \
-I$(ACE_ROOT)/Kokyu \
- -I$(TAO_ROOT)/examples/Kokyu_dsrt_schedulers \
- -I$(TAO_BUILDDIR)/examples/Kokyu_dsrt_schedulers
+ -I$(TAO_ROOT)/examples/Kokyu_dsrt_schedulers
fp_client_SOURCES = \
client.cpp \
testC.cpp \
- test_i.h \
- test_i.i
+ testC.h \
+ testC.inl \
+ testS.h \
+ testS_T.h \
+ testS_T.inl
fp_client_LDADD = \
$(top_builddir)/examples/Kokyu_dsrt_schedulers/libKokyu_DSRT_Schedulers.la \
@@ -93,6 +89,35 @@ endif BUILD_RT_CORBA
if BUILD_RT_CORBA
+BUILT_SOURCES += \
+ testC.cpp \
+ testC.h \
+ testC.inl \
+ testS.cpp \
+ testS.h \
+ testS.inl \
+ testS_T.cpp \
+ testS_T.h \
+ testS_T.inl
+
+CLEANFILES += \
+ test-stamp \
+ testC.cpp \
+ testC.h \
+ testC.inl \
+ testS.cpp \
+ testS.h \
+ testS.inl \
+ testS_T.cpp \
+ testS_T.h \
+ testS_T.inl
+
+testC.cpp testC.h testC.inl testS.cpp testS.h testS.inl testS_T.cpp testS_T.h testS_T.inl: test-stamp
+
+test-stamp: $(srcdir)/test.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/test.idl
+ @touch $@
+
noinst_PROGRAMS += fp_server
fp_server_CPPFLAGS = \
@@ -101,14 +126,18 @@ fp_server_CPPFLAGS = \
-I$(TAO_ROOT) \
-I$(TAO_BUILDDIR) \
-I$(ACE_ROOT)/Kokyu \
- -I$(TAO_ROOT)/examples/Kokyu_dsrt_schedulers \
- -I$(TAO_BUILDDIR)/examples/Kokyu_dsrt_schedulers
+ -I$(TAO_ROOT)/examples/Kokyu_dsrt_schedulers
fp_server_SOURCES = \
server.cpp \
testC.cpp \
testS.cpp \
test_i.cpp \
+ testC.h \
+ testC.inl \
+ testS.h \
+ testS_T.h \
+ testS_T.inl \
test_i.h \
test_i.i