summaryrefslogtreecommitdiff
path: root/TAO/examples/Kokyu_dsrt_schedulers/mif_example/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/examples/Kokyu_dsrt_schedulers/mif_example/Makefile.am')
-rw-r--r--TAO/examples/Kokyu_dsrt_schedulers/mif_example/Makefile.am73
1 files changed, 51 insertions, 22 deletions
diff --git a/TAO/examples/Kokyu_dsrt_schedulers/mif_example/Makefile.am b/TAO/examples/Kokyu_dsrt_schedulers/mif_example/Makefile.am
index fc8a40e661c..ec056f1b1dd 100644
--- a/TAO/examples/Kokyu_dsrt_schedulers/mif_example/Makefile.am
+++ b/TAO/examples/Kokyu_dsrt_schedulers/mif_example/Makefile.am
@@ -16,47 +16,41 @@ TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
+CLEANFILES =
noinst_PROGRAMS =
+BUILT_SOURCES =
-## Makefile.mif_example_IDL.am
+## Makefile.mif_client.am
-BUILT_SOURCES = \
+if BUILD_RT_CORBA
+
+BUILT_SOURCES += \
testC.cpp \
testC.h \
testC.inl \
- testS.cpp \
testS.h \
testS.inl \
testS_T.cpp \
testS_T.h \
testS_T.inl
-CLEANFILES = \
+CLEANFILES += \
test-stamp \
testC.cpp \
testC.h \
testC.inl \
- testS.cpp \
testS.h \
testS.inl \
testS_T.cpp \
testS_T.h \
testS_T.inl
-testC.cpp testC.h testC.inl testS.cpp testS.h testS.inl testS_T.cpp testS_T.h testS_T.inl: test-stamp
+testC.cpp testC.h testC.inl testS.h testS.inl testS_T.cpp testS_T.h testS_T.inl: test-stamp
test-stamp: $(srcdir)/test.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/test.idl
+ $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/test.idl
@touch $@
-
-noinst_HEADERS = \
- test.idl
-
-## Makefile.mif_example_client.am
-
-if BUILD_RT_CORBA
-
noinst_PROGRAMS += mif_client
mif_client_CPPFLAGS = \
@@ -65,14 +59,16 @@ mif_client_CPPFLAGS = \
-I$(TAO_ROOT) \
-I$(TAO_BUILDDIR) \
-I$(ACE_ROOT)/Kokyu \
- -I$(TAO_ROOT)/examples/Kokyu_dsrt_schedulers \
- -I$(TAO_BUILDDIR)/examples/Kokyu_dsrt_schedulers
+ -I$(TAO_ROOT)/examples/Kokyu_dsrt_schedulers
mif_client_SOURCES = \
client.cpp \
testC.cpp \
- test_i.h \
- test_i.i
+ testC.h \
+ testC.inl \
+ testS.h \
+ testS_T.h \
+ testS_T.inl
mif_client_LDADD = \
$(top_builddir)/examples/Kokyu_dsrt_schedulers/libKokyu_DSRT_Schedulers.la \
@@ -89,10 +85,39 @@ mif_client_LDADD = \
endif BUILD_RT_CORBA
-## Makefile.mif_example_server.am
+## Makefile.mif_server.am
if BUILD_RT_CORBA
+BUILT_SOURCES += \
+ testC.cpp \
+ testC.h \
+ testC.inl \
+ testS.cpp \
+ testS.h \
+ testS.inl \
+ testS_T.cpp \
+ testS_T.h \
+ testS_T.inl
+
+CLEANFILES += \
+ test-stamp \
+ testC.cpp \
+ testC.h \
+ testC.inl \
+ testS.cpp \
+ testS.h \
+ testS.inl \
+ testS_T.cpp \
+ testS_T.h \
+ testS_T.inl
+
+testC.cpp testC.h testC.inl testS.cpp testS.h testS.inl testS_T.cpp testS_T.h testS_T.inl: test-stamp
+
+test-stamp: $(srcdir)/test.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/test.idl
+ @touch $@
+
noinst_PROGRAMS += mif_server
mif_server_CPPFLAGS = \
@@ -101,14 +126,18 @@ mif_server_CPPFLAGS = \
-I$(TAO_ROOT) \
-I$(TAO_BUILDDIR) \
-I$(ACE_ROOT)/Kokyu \
- -I$(TAO_ROOT)/examples/Kokyu_dsrt_schedulers \
- -I$(TAO_BUILDDIR)/examples/Kokyu_dsrt_schedulers
+ -I$(TAO_ROOT)/examples/Kokyu_dsrt_schedulers
mif_server_SOURCES = \
server.cpp \
testC.cpp \
testS.cpp \
test_i.cpp \
+ testC.h \
+ testC.inl \
+ testS.h \
+ testS_T.h \
+ testS_T.inl \
test_i.h \
test_i.i