summaryrefslogtreecommitdiff
path: root/TAO/examples/Logging/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/examples/Logging/Makefile.am')
-rw-r--r--TAO/examples/Logging/Makefile.am49
1 files changed, 41 insertions, 8 deletions
diff --git a/TAO/examples/Logging/Makefile.am b/TAO/examples/Logging/Makefile.am
index 428952e676a..b421072f5b7 100644
--- a/TAO/examples/Logging/Makefile.am
+++ b/TAO/examples/Logging/Makefile.am
@@ -16,7 +16,7 @@ TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
-## Makefile.Logging_IDL.am
+## Makefile.Logging_Service.am
BUILT_SOURCES = \
LoggerC.cpp \
@@ -44,15 +44,9 @@ CLEANFILES = \
LoggerC.cpp LoggerC.h LoggerC.inl LoggerS.cpp LoggerS.h LoggerS.inl LoggerS_T.cpp LoggerS_T.h LoggerS_T.inl: Logger-stamp
Logger-stamp: $(srcdir)/Logger.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/Logger.idl
+ $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs $(srcdir)/Logger.idl
@touch $@
-
-noinst_HEADERS = \
- Logger.idl
-
-## Makefile.Logging_Service.am
-
noinst_PROGRAMS = Logging_Service
Logging_Service_CPPFLAGS = \
@@ -69,6 +63,11 @@ Logging_Service_SOURCES = \
Logger_i.cpp \
Logging_Service.cpp \
Logging_Service_i.cpp \
+ LoggerC.h \
+ LoggerC.inl \
+ LoggerS.h \
+ LoggerS_T.h \
+ LoggerS_T.inl \
Logger_i.h \
Logging_Service_i.h
@@ -84,6 +83,35 @@ Logging_Service_LDADD = \
## Makefile.Logging_Test.am
+BUILT_SOURCES += \
+ LoggerC.cpp \
+ LoggerC.h \
+ LoggerC.inl \
+ LoggerS.cpp \
+ LoggerS.h \
+ LoggerS.inl \
+ LoggerS_T.cpp \
+ LoggerS_T.h \
+ LoggerS_T.inl
+
+CLEANFILES += \
+ Logger-stamp \
+ LoggerC.cpp \
+ LoggerC.h \
+ LoggerC.inl \
+ LoggerS.cpp \
+ LoggerS.h \
+ LoggerS.inl \
+ LoggerS_T.cpp \
+ LoggerS_T.h \
+ LoggerS_T.inl
+
+LoggerC.cpp LoggerC.h LoggerC.inl LoggerS.cpp LoggerS.h LoggerS.inl LoggerS_T.cpp LoggerS_T.h LoggerS_T.inl: Logger-stamp
+
+Logger-stamp: $(srcdir)/Logger.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs $(srcdir)/Logger.idl
+ @touch $@
+
noinst_PROGRAMS += Logging_Test
Logging_Test_CPPFLAGS = \
@@ -99,6 +127,11 @@ Logging_Test_SOURCES = \
LoggerS.cpp \
Logging_Test.cpp \
Logging_Test_i.cpp \
+ LoggerC.h \
+ LoggerC.inl \
+ LoggerS.h \
+ LoggerS_T.h \
+ LoggerS_T.inl \
Logging_Test_i.h
Logging_Test_LDADD = \