summaryrefslogtreecommitdiff
path: root/TAO/examples/OBV/Typed_Events/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/examples/OBV/Typed_Events/Makefile.am')
-rw-r--r--TAO/examples/OBV/Typed_Events/Makefile.am13
1 files changed, 7 insertions, 6 deletions
diff --git a/TAO/examples/OBV/Typed_Events/Makefile.am b/TAO/examples/OBV/Typed_Events/Makefile.am
index bd482fdf39b..783713a39b9 100644
--- a/TAO/examples/OBV/Typed_Events/Makefile.am
+++ b/TAO/examples/OBV/Typed_Events/Makefile.am
@@ -13,7 +13,7 @@ ACE_ROOT = $(top_srcdir)/..
TAO_BUILDDIR = $(top_builddir)
TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
-TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
noinst_PROGRAMS =
@@ -40,15 +40,16 @@ CLEANFILES = \
Event_TypesC.cpp Event_TypesC.h Event_TypesC.inl Event_TypesS.cpp Event_TypesS.h Event_TypesS.inl: Event_Types-stamp
Event_Types-stamp: $(srcdir)/Event_Types.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) -Sa $(srcdir)/Event_Types.idl
+ $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/Event_Types.idl
@touch $@
+
noinst_HEADERS = \
Event_Types.idl
## Makefile.Typed_Events_Client.am
-if BUILD_EXCEPTIONS
+if !BUILD_MINIMUM_CORBA
noinst_PROGRAMS += client
@@ -79,11 +80,11 @@ client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-endif BUILD_EXCEPTIONS
+endif !BUILD_MINIMUM_CORBA
## Makefile.Typed_Events_Server.am
-if BUILD_EXCEPTIONS
+if !BUILD_MINIMUM_CORBA
noinst_PROGRAMS += server
@@ -114,7 +115,7 @@ server_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-endif BUILD_EXCEPTIONS
+endif !BUILD_MINIMUM_CORBA
## Clean up template repositories, etc.
clean-local: