summaryrefslogtreecommitdiff
path: root/TAO/examples/POA/DSI/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/examples/POA/DSI/Makefile.am')
-rw-r--r--TAO/examples/POA/DSI/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/TAO/examples/POA/DSI/Makefile.am b/TAO/examples/POA/DSI/Makefile.am
index 4aa9389ef7e..4e949a08ed5 100644
--- a/TAO/examples/POA/DSI/Makefile.am
+++ b/TAO/examples/POA/DSI/Makefile.am
@@ -13,7 +13,7 @@ ACE_ROOT = $(top_srcdir)/..
TAO_BUILDDIR = $(top_builddir)
TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
-TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_IDLFLAGS = -Ge 1 -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
TAO_ROOT = $(top_srcdir)
noinst_PROGRAMS =
@@ -43,13 +43,14 @@ Database-stamp: $(srcdir)/Database.idl $(TAO_IDL_DEP)
$(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/Database.idl
@touch $@
+
noinst_HEADERS = \
Database.idl
## Makefile.POA_DSI_Client.am
if BUILD_CORBA_MESSAGING
-if BUILD_EXCEPTIONS
+if !BUILD_MINIMUM_CORBA
noinst_PROGRAMS += client
@@ -74,13 +75,13 @@ client_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-endif BUILD_EXCEPTIONS
+endif !BUILD_MINIMUM_CORBA
endif BUILD_CORBA_MESSAGING
## Makefile.POA_DSI_Server.am
if BUILD_CORBA_MESSAGING
-if BUILD_EXCEPTIONS
+if !BUILD_MINIMUM_CORBA
noinst_PROGRAMS += server
@@ -108,7 +109,7 @@ server_LDADD = \
$(TAO_BUILDDIR)/tao/libTAO.la \
$(ACE_BUILDDIR)/ace/libACE.la
-endif BUILD_EXCEPTIONS
+endif !BUILD_MINIMUM_CORBA
endif BUILD_CORBA_MESSAGING
## Clean up template repositories, etc.